Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just upgraded to Ubuntu 12.04 and I found a weird behaviour in the multi-workspace management.

Let's say that I have a couple of terminals opened in one workspace, and that I want to do something else in another workspace. I move to that workspace and then I click on the terminal icon. Immediately I am taken to the initial workspace.

This is similar to the multiple workspace behaviour in Os X and it is entirely undesirable. How can I disable the application-workspace association in 12.04?


share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.