Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I just removed some effects using ccsm, switched to the AMD proprietary driver, rebooted and after I log in, the unity panel is no longer there. If I hit the windows key or the alt key, nothing happens. I can hit ctrl+alt+t to get a terminal (and thus launch apps via commandline).

Does anyone know how I can fix this? What logs do I need to post here for help?

Edit #1:

As suggested by @cprofitt I just ran:

dconf reset -f /org/compiz/ && setsid unity

I'm seeing some compiz messages in the terminal now:

unity-panel-service: no process found
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: opengl
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  23
  Current serial number in output stream:  23
compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  23
  Current serial number in output stream:  23
compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).
compiz (core) - Info: Starting plugin: opengl
Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0
compiz (core) - Error: Plugin initScreen failed: opengl
compiz (core) - Error: Failed to start plugin: opengl
compiz (core) - Info: Unloading plugin: opengl
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Error: Plugin 'opengl' not loaded.
share|improve this question

marked as duplicate by Seth, Luis Dec 9 '13 at 0:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

6 Answers 6

up vote 29 down vote accepted

Try the following:

Type the following in to a terminal:

dconf reset -f /org/compiz/

then

setsid unity

If this is an issue with Unity settings that will reset your config to default.

I hope that helps.

share|improve this answer
1  
This helped me after I upgraded from 12.10 to 13.04 and everything was missing. Awesome! –  itnet7 Apr 26 '13 at 22:28
    
@cprofitt, could you explain why setsid unity not just unity ? , your answer solved my problem but I don't understand the second part –  Mohammad AbuShady Sep 2 '13 at 16:56

So I ended up re-installing lightdm & ubuntu-desktop as per Can't install ATI proprietary drivers in 12.10

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

And then rebooted

From what I can tell the AMD driver is now installed.

brad@saro:~$ fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series 
OpenGL version string: 4.2.11903 Compatibility Profile Context

brad@saro:~$ fgl_glxgears 
Using GLX_SGIX_pbuffer
1499 frames in 5.0 seconds = 299.800 FPS
1663 frames in 5.0 seconds = 332.600 FPS
share|improve this answer
1  
FWIW, I stupidly installed nvidia-current on a 13.04 VM, and it nuked the unity desktop. I tried purging the nvidia* packages to no avail. These commands finally helped me restore everything. –  karlgrz Apr 2 '13 at 20:53

I installed Ubuntu with the windows installer on a Compaq Presario 7000US (old Computer) that I have currently running WinXP. I came upon this problem and was very close to just giving up on Ubuntu because of this same issue.

When I tried sudo apt-get purge fglrx, it returned with a note saying the package was not removed because it was not installed so instead I did

sudo apt-get install fglrx

It downloaded the package and installed it. After it was done, the side bar (is that was its called ?) appeared.

It seems a bit slow but now it gives me more incentive to continue to work on this machine.

share|improve this answer

I had this same issue this morning, and after hours of troubleshooting, I figured out what the problem was. The problem is with Compiz, but you can't just simply close Compiz and restart it, the problem will still be there. what I did is login and of course unity won't show up.

Just hit Ctrl + Alt + T to open a terminal and type ccsm to load the Compiz Config Settings Manager.

Now you need to look for the Ubuntu Unity Plugin, click it and you'll notice that it's not enabled, just enable it, and it'll bring some windows up with conflicts, just read them and click the options that you want and unity will be back!

For me, when I clicked enable and closed that window, it didn't work the first time but I did it a second time, and it worked!

share|improve this answer
    
What if the user doesn't have the ccsm installed? –  Braiam Sep 1 '13 at 13:22
    
OMG!!! this works! Happened when removing broken nvidia-current... You just saved me from a reinstall. –  Ciro Santilli Oct 19 '13 at 13:37

I had a same problem: upgrade from 12.04 to 12.10 and then to 13.04. Unity was broken and only reseting unity

dconf reset -f /org/compiz/
setsid unity

wasn't help. I tried to do what hafichuk explained above:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

and then

dconf reset -f /org/compiz/
setsid unity

and it worked. Thank you.

share|improve this answer

I was trying almost all the suggestions posting in the forum.

My case was similar (No GUI post installation on VMware Workstation).

And the solution worked for me is.....

sudo lightdm
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.