Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated to Ubuntu 12.10 today from 12.04 using the graphical update tool. Everything seemed to be fine until I went to open Nautilus, and it would not open. Bizarrely, I am able to open a file that I happen to have on my desktop, but when I click on the launcher, it never opens. When I enter 'nautilus' in the terminal, I get this:

    (nautilus:8557): Gdk-CRITICAL **: gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' failed
    zsh: segmentation fault (core dumped)  nautilus

I am not a total novice with ubuntu or linux, but all I can tell is that there is some problem with X. Can someone please point me in the right direction as far as fixing this? I really don't want to have to do a fresh install. Thank you very much.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I have updated my Nautilus and since the update I experience the same issues, obviously this is a bug in the current release and will hopefully get fixed as soon as possible.

if you want to get it back to work you either wait for an update or you roll back to Nautilus 3.4, using the following command:

 sudo ppa-purge ppa:gnome3-team/gnome3

if you haven't installed it yet, just run

sudo aptitude install ppa-purge

it should be in the offical repository, if this is not the case, here is the ppa

ppa purge ppa

EDIT: the latest update of Nautilus solved this issue, its now possible to use nautilus 3.6 again!

share|improve this answer
    
Awesome, that worked! As a side note, you probably want to edit the typo in 'aptitude' for anyone looking for the same info who wouldn't know better. –  dereksalerno Oct 22 '12 at 17:47
    
edited it, thanks for the hint and glat it worked for you –  Stefan Oct 23 '12 at 23:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.