Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

testing juju from the ppa on aws on precise.

Environment successfully bootstrapped, mysql and wordpress unit started, db relationship successfully added. On exposure of wordpress I have no open ports (which IMO should be configured by the charm -- tried to upgrade charm, but already using latest wordpress-9 from the ppa).

open-ports: []

I would like to open the port, but why do I have to do it manually? And how can I do it?

I tried to use the open-port command, but it asks for a JUJU_CLIENT_ID and a JUJU_AGENT_SOCKET which I am not sure what they should point at.

I have read online other users don't need to open ports... it should work OOTB.

Juju status FYR:

    agent-state: running
    instance-id: yyy
    instance-state: running
    charm: cs:precise/mysql-8
      - wordpress
        agent-state: started
        machine: 0
    charm: cs:precise/wordpress-9
    exposed: true
      - mysql
      - wordpress
        agent-state: started
        machine: 0
        open-ports: []
share|improve this question
Can you post the output from /var/lib/juju/units/wordpress-0/charm.log in to something like There's a chance that something went wrong during hook execution. – Marco Ceppi Oct 22 '12 at 14:53
Darn... solved it. Basically it had nothing to do with Juju. The TCP port is not open by default in a newly spawned EC2 instance. Once added the ule in my security group on exposure of wordpress port 80/tcp is open. All is good now. – pberto Oct 23 '12 at 1:00
That's not how Juju works. When you run a juju expose wordpress Juju actually creates a security group and applies the port rules to that group. You may still be experiencing an issue or a bug with either Juju or the charm – Marco Ceppi Oct 23 '12 at 1:53
@pberto, could you please update the community wiki answer below with the exact steps you took to resolve this issue? Thanks. – ppetraki Oct 23 '12 at 14:46


After I did a juju expose wordpress the charm was exposed (see my first post's juju status: exposed: true) BUT the port was NOT open. Hence I manually opened it by editing the instance security group allowing port 80. Note that my juju environment is set to have placement: local. I understand this is not a general solution, but it worked in my specific case.


I agree this is not a solution and I am pretty certain there is a bug somewhere in either juju or the charm. If I can help please let me know.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.