Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ma78gm-s2h mainboard and gtx260, there is no sound on ubuntu. There is a spdif connection from my videocard to mainboard. And it connected with hdmi to my tv. It works fine with windows but not with ubuntu. Is there any way to fix this? I tried everything like troubleshooting, nvidia driver, alc889 driver etc.

Edit: there is only analog and digital choices exist at settings

share|improve this question

2 Answers 2

I had to download the proprietary driver for my ATI card and then I had the option to select HDMI sound. It worked after that. Hope this helps.

"To use a proprietary driver for a device:

Press System → Administration → Hardware Drivers.

Find the driver which you would like to enable and read the description.

Press Activate to enable the driver. You may be asked to enter your password.

The proprietary driver may have to be downloaded and installed.

You may need to restart your computer to finish enabling the driver. "

share|improve this answer

Maybe your problem is just a sofware configuration. Connect your Ubuntu with the HDMI output and go to Sound Settings... Then in the tab Output you can choose in a list where to send your audio output, try out each option of the list!

share|improve this answer
    
I have already tried this. :/ –  baris ozgur Oct 22 '12 at 1:48
    
Sorry, it worked for me, I think I can't help you so far. –  Rodrigo Martins Oct 22 '12 at 1:49
    
i s that normal there is no choice like hdmi audio under options? –  baris ozgur Oct 22 '12 at 1:51
    
No, in the list of devices, when I plug-in the HDMI cable on my computers, it always appears HDMI audio output option. It's strange that you don't have this option, you could try one of the related questions on the right side of this page, like: askubuntu.com/questions/93905/… or askubuntu.com/questions/32897/… –  Rodrigo Martins Oct 22 '12 at 20:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.