Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've lost my Unity after sudo apt-get autoremove --purge unity-webapp and cleaned the system with Ubuntu Tweak.

I try to install it, but I always get a warning of broken dependencies... I've added the Unity Team PPA, dist-upgrade, among other efforts. (same with Unity 2D)

When I try to install ubuntu-desktop I get this:
E: Unable to correct problems, you have held packages (hold) spoiled.

Please help me!

[Ubuntu 12.10]

share|improve this question

closed as too localized by Jorge Castro, Tom Brossman, theDefector, RolandiXor, Mitch Oct 22 '12 at 19:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

It might be best to reinstall and not 'clean the system' or add any PPAs right away. The further you move from the default install, the greater the likelihood that things can break. – Tom Brossman Oct 22 '12 at 7:39
But who can I solve de problem now? – Sardinha 94410 Oct 22 '12 at 8:48

1 Answer 1

I would personaly try this maybe itll help for you reinstall ubuntu-desktop by running: sudo apt-get install --reinstall ubuntu-desktop , then another command: sudo apt-get install reinstall unity If its not working try: sudo apt-get update -f and then sudo apt-get -f install or else sudo apt-get install aptitude and sudo apitude safe-upgrade. I would also try command sudo apt-get check to see broken needed dependencies and install them .Hope it helps or just google fixing broken packages ubuntu

share|improve this answer
Thank you! I managed to resolve the broken packages and install Unity. But unfortunately I still have a problem ... My Unity does not appear. It is as if not installed! What is causing this? How can I solve? – Sardinha 94410 Oct 22 '12 at 19:59
have you tried sudo apt-get install --reinstall unity if you have then summon the terminal by pressing cntrl alt t and type ccsm if compiz settings manager not installed use command suggested in terminal then run ccsm and see ubuntu unity plugin just check if its enabled in options – polarkatenuchie Oct 22 '12 at 20:09
Installed, open the application and the Unity plugin was active. I uncheck, checked it again and ccsm resolved some conflicts. After that rebooted, but still not appear the Unity ... ?? – Sardinha 94410 Oct 23 '12 at 1:15
it says that your hardware is not supported in info. I guess u should try & check if its working in low graphic mode… if unity interface works on your pc in 12.04 fine then i see no reason to use this release until they fix issues in few mounths cause for now its quite unstable. – polarkatenuchie Oct 23 '12 at 9:32
i was trying to say its unstable at least for now. Try: sudo dpkg --remove --force-remove-reinstreq unity-webapps , sudo apt-get install webapps, sudo apt-get install unity-webapps-common.Then remove unity ppa repository that you added from software source list and run: sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install-reinstall unity – polarkatenuchie Oct 23 '12 at 10:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.