Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded to GNU/Linux Ubuntu 12.10 but have been unable to use Unity properly afterwards. Indeed, I encountered the exact same problem as a lot of people: the Unity side and top bars are not displaying, although in my case, Unity seems completely broken, as I can't even right-click. However, in my case, it's worth noticing that I have an Optimus laptop with a Nvidia graphics card (GeForce GT 540M). Bumblebee and its 'optirun' command is working just fine, as usual, after the upgrade.

I tried several things, as resetting Compiz and Unity (with the command 'setside unity') -- which works but I have to do it everytime I boot and it resets all my settings -- updating/reinstalling/reconfiguring my Nvidia drivers as well as bumblebee, trying with Nouveau drivers instead of nvidia-current, check if linux-headers-generic were installed (they were). However, I couldn't reset xorg.conf files as they're just not there. There is neither xorg.conf file, nor its backup in /etc/X11. I think this is where the problem comes from, although I'm far from an expert. Maybe retrieving a xorg.conf file will fix this mess, but I have no idea how to do that.

I'm just tired and don't know what to do. So, here I am, begging for your help.

share|improve this question

On my Dell XPS 15z (Optimus graphics), I had the same problem. I managed to get the computer working again by completely removing all the nvidia drivers. (For me, it was not enough to simply remove xorg.conf; instead, the nvidia drivers had to be completely uninstalled.)

This is what I did: note that you can open a terminal by pressing ctrl+alt+T

sudo apt-get purge nvidia*
sudo rm /etc/X11/xorg.conf
sudo dpkg-reconfigure xserver-xorg

then rebooted.

Of course, this is not ideal, because the nvidia graphics is completely useless, but it will give a working desktop.

share|improve this answer
Thanks for the reply! However, like mentioned previously, I don't have any xorg.conf file so the second command failed. The rest succeeded but it had no effect: still the same problem. – SyS Oct 22 '12 at 10:15

I have the Nvidia Geforce GTX 560M which also uses the proprietary drivers. Basically what I did was,

  1. open terminal or a shell

  2. run command: sudo apt-get install linux-source

  3. run command: sudo apt-get install linux-headers-3.5.0-17-generic

  4. run command: sudo apt-get install nvidia-current-updates

Then reboot the computer. That worked for me anyway.

share|improve this answer
Thanks!However, I can't do that as nvidia-current-updates is not compatible with bumblebee (community-made, open-source Nvidia Optimus technology), which is required if I want to use my graphics card (I play games sometimes). – SyS Oct 22 '12 at 10:51

If you use bumbleblee simply reinstall it. bumbleblee on ubuntu

I had exactly the same problem and it solved the fact that unity was broken.

share|improve this answer
Thansks for the reply! But this had no effect. :/ – SyS Oct 24 '12 at 17:42

i would try to reinstall desktop: sudo apt-get install --reinstall ubuntu-desktop then run: sudo apt-get install --reinstall unity . Usefull info that might help command to restart Unity: setsid unity ,to restart Compiz: setsid compiz --replace ,restart X Display: Manager: sudo -s , then run: setsid service lightdm restart

share|improve this answer
I reinstalled/erased the configuration files of both Compiz and Unity, but the result is the same. – SyS Oct 30 '12 at 14:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.