Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Did a clean install of Ubuntu 12.10 from 12.04 and the sound is not working now. In 12.04 it worked out of the box.

I ran hwinfo --sound

hal.1: read hal dataprocess 4222: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 282.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
10: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.318]
  Unique ID: u1Nb.ekgK5auW5RA
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Intel 82801G (ICH7 Family) High Definition Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x27d8 "82801G (ICH7 Family) High Definition Audio Controller"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x01de 
  Revision: 0x01
  Memory Range: 0xfdffc000-0xfdffffff (rw,non-prefetchable)
  IRQ: 11 (no events)
  Module Alias: "pci:v00008086d000027D8sv00001028sd000001DEbc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Not sure how to proceed to fix this. Has also worked prior to this version.

How to resolve this ?

share|improve this question
    
I have the same problem can't say I've fixed it, but my computer has front and rear audio jacks and my speakers are plugged into rear jack as expected. However, plugging in my headphones into the front jack to my surprise I have sound! So that is progress. Even on windows on the same box I had remember I had to jump through some hoops to get the audio to work properly from the rear jacks. –  User Jan 29 '13 at 21:29

5 Answers 5

I fixed it by running alsamixer, and changing AUTO-MUTE MODE from ENABLE to DISABLE.

share|improve this answer
1  
Well you see, this solved my problem, so don't go rushing into comments either :) –  Piero Oct 24 '12 at 19:25
    
Ditto here. Sounds was randomly cutting out, and this fixed it. –  Just a guy Oct 25 '12 at 2:53
    
solved for me too, thanks! –  nyne Jan 11 '13 at 2:47

Fought with this problem for a while, and finally found the solution here: https://bbs.archlinux.org/viewtopic.php?pid=115808

Not really sure what it does or what other concequences it might have, but I added

blacklist i82975x_edac

to

/etc/modprobe.d/blacklist.conf

(reboot)

Sound works now and the "Dummy Output" is replaced by a real soundcard.

share|improve this answer

I personally found this useful:

How to Resolve No sound Problem On Ubuntu 12.10, 12.04 And Older (unixmen)

share|improve this answer
1  
Can you add some of the major points of the link to your answer please? In case the link goes down, the key steps / points will be given here as well. –  Thomas W. Oct 27 '12 at 22:19

Same here. I use a optical audio output, which worked out of the box with 12.04.

I was able to make sound working again by opening up the Audio Config Tab (in the gnome-control-center) and instead of the analog device, I selected the digital S/PDIF as output device.

Hopefully the settings are stored after reboot.

share|improve this answer
1  
All that I have listed is "Dummy Output". My sound card is not even listed anymore. –  ZooRocket Oct 21 '12 at 20:01

I was having similar issues. I could get sound from my laptop as normal, but if I fitted the headphones, I got nothing.

I followed the instruction in the following link, and had immediate success.

http://docs.oseems.com/general/operatingsystem/ubuntu/fix-no-sound-headphone-jack-dell-xps-studio-16

share|improve this answer

protected by Community Mar 23 '13 at 20:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.