Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems after I tried to change the login screen background with Ubuntu Tweak, the greeter's background stays a simple purple background with just the spots..

I tried using dconf-editor, rechanging the image from Ubuntu Tweak back to the default, it still does not work.

So In The End, everything for the lightdm points to /usr/share/backgrounds/warty-final-ubuntu.png.

But it's still a purple solid color. How do I fix it?

share|improve this question

4 Answers 4

It's possible the picture file you're trying to use does not have the proper permissions to be viewed by others. Since you are logging on in LightDM and not yet known, the system can not display files which are limited access.

To make a file accessible for the LightDM screen, right-click on the file in Nautilus and select Properties, then Permissions and make sure "Access" is not set to "None" for "Group" or "Others".

Nautilus File Permissions tab

Also note that the LightDM background defaults to the background of whatever user is highlighted in the log in space.

share|improve this answer
2  
BTW, setting a user's background picture access to owner only is a way to intentionally have the default background on the LightDM screen as answered at askubuntu.com/questions/134762/… –  James Oct 22 '12 at 22:42

There's another thing to keep in mind. If the picture is not located in your ~/Pictures folder, it will not work. Not even if you put it in a sub-directory of that folder.

I tried a lot of different possibilities, and the only one that works is to give both group and others at least Read-only access, place the image in your Pictures folder and change your background, selecting the Pictures folder from the dropdown box.

Logout, et voila, there's your background.

share|improve this answer

Sorry it has been a while.. I took a break from UNIX for a while.. And came back still frustrated.. I have done all things eferyone has reccomended and even uninstalled and reinstalled lightdm.. But still no good..

Is reinstalling ubuntu my only hope now?

share|improve this answer

try to restart X Display: Manager:

sudo -s
setsid service lightdm restart

,maybe it will make the difference to restart unity and compiz to default

Restart Unity: setsid unity
Restart Compiz: setsid compiz --replace
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.