Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have install Ubuntu 12.10 64 bit on my Dell Latitude E6400 laptop. I have the latest bios version for my laptop (A32) which I downloaded from the official Dell website by checking updates that matches the service tag on my laptop.

I'm having serious problems with all the mouse buttons on my laptop. The right-click button doesn't work at all under any circumstance. The left click button only work when clicking on icons in the left side-bar and in the top menu (like clicking on the power icon in the top-right corner or clicking on the file menu).

However none of the buttons work in any of the applications even simple one like the file browser (home folder). For example when I try to click on a folder inside nautilus it doesn't work or when I try to click on the "x" close icon to close the window it also doesn't work.

Can you help me figure it out?

share|improve this question
    
Hi, I also did xinput list and my touchpad is shown there is an "Alps/PS2 Dual Point..." which is correct since the dell latitude e6400 doesn't use a synaptic touchpad. I tried many linux distributions such as linux mint and xubuntu and now ubuntu but I'm having the same problems in all of them. Do you guys know of any solution to this problem? Thanks –  Ido Oct 22 '12 at 19:00

1 Answer 1

I was facing exactly the same problem with my touchpad on Ubuntu 12.10 (left click worked only on left unity panel and top menu bar). It occurred occasionally.

Simply restarting the mousepad from the command line fixed it for me. No need for logging out or rebooting. The commands are mentioned here.

Another solution mentioned here is to uncheck the option in system settings. This might be a fix for the long run, but if your touchpad is currently hung/frozen then restarting the touchpad should fix the problem.

Otherwise, try logging out and/or rebooting

Edit: Also ensure that no Unity lens or HUD is active in the background (invisible). The symptoms mentioned by you (mouse click only works in left unity panel and top menu bar) is exactly the behaviour when any unity lens/HUD is active. Just press escape 3-4 times, that should close any invisible but active unity lens/HUD. I've updated my blog post with these details and also outlined a way through which you can reproduce this invisible HUD problem.

share|improve this answer
    
Hi, Thanks for your details answered. However to me this issue arises all the time. I restart the mouse by using modprobe and then it works, I'm able to click on the "x" icon to close the terminal window. However a second later when I open the file browser the mouse stops working. This happens consistently. One weird phenomenon that I see is that when ever I restart my mouse it always do a right-click because I can see the context popup. Do you know if there is any solution to that? Thanks –  Ido Oct 27 '12 at 9:47
    
Forgot to mention that to be sure I press escape several times to close any unity lens/HUD, but it still doesn't help. –  Ido Oct 27 '12 at 9:48
    
try this as well - inforbiro.com/blog-eng/ubuntu-12-04-frozen-touchpad... its just another way to restart the touchpad but do give it a try.. the function key combination for your laptop might be different.. –  nhylated Nov 2 '12 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.