Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got the following problem:

My PC shut down while upgrading from 12.04 to 12.10. Everything seems to work but I can't install the missing updates. It always tells me to run apt-get install -f, but when I do so it just says: (It's in German, hope it doesn't matter)

Reading package lists ... Ready
Dependency tree
Status information is read ... Ready
Dependencies can be corrected ... Ready
The following packages were automatically installed and are no longer needed:
espeak gcc-4.6-base: i386 gir1.2-notify-0.7-1.2-29 libcamel libebook-1.2-12
libedataserver-1.2-15-bluetooth8 libgconf2-4 libgnome libgnome-menu2
libgnomekbd7 libgomp1: i386 libgweather-3-0 libimobiledevice2 libindicate5
libkpathsea5 libpoppler19 libusbmuxd1 python-gmenu
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
nvidia-current-updates xserver-xorg-core xserver-xorg-input-evdev
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-vmmouse xserver-xorg-input-wacom
xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-nouveau
xserver-xorg-video-openchrome xserver-xorg-video-qxl
xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-vesa xserver-xorg-video-vmware
Suggested packages:
xfonts-100dpi xfonts-75dpi gpointing-device-settings touchfreeze
firmware-linux
The following packages will be REMOVED:
nvidia-current
The following packages will be upgraded (upgrade):
nvidia-current-updates xserver-xorg-core xserver-xorg-input-evdev
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-vmmouse xserver-xorg-input-wacom
xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-nouveau
xserver-xorg-video-openchrome xserver-xorg-video-qxl
xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-vesa xserver-xorg-video-vmware
20, upgraded, 0 newly installed, 1 to remove and 133 not upgraded.
8 not fully installed or removed.
Need to get 0 B of 70.6 MB to be downloaded archives.
After this operation, 184 MB disk space will be freed.
Would you like to [Y / n] continue? j
(Reading database ... 242727 files and directories currently installed.)
Removing nvidia-current ...
Removing all DKMS Modules
Error! There are no instances of module: nvidia-current
295.40 situated in the DKMS tree.
Done.
Traceback (most recent call last):
File "/ usr / bin / quirks-handler", line 26, in <module>
import Quirks.quirkapplier
File "/ usr/lib/python2.7/dist-packages/Quirks/quirkapplier.py", line 26, in <module>
import XKit.xutils
ImportError: No module named XKit.xutils
dpkg: error processing nvidia-current (- remove):
Subprocess installed pre-removal script returned error exit status 1
Trigger for bamfdaemon be processed ...
Rebuilding / usr / share / applications / bamf.index ...
Triggers for libc-bin to be processed ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
nvidia-current
E: Sub-process / usr / bin / dpkg returned an error code (1)

When I try to remove nvidia-current it tells me to run apt-get install -f.

Do you guys have any idea? I don't want to reinstall my whole system, takes a lot of time to encrypt everything again and so on.

share|improve this question
    
Here's the result of sudo apt-get -f install, do you know what could be a fix to the problem? sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: linux-headers-3.2.0-44-generic linux-headers-3.2.0-44 Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 2 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Setting up nvidia-current (304.88-0ubuntu0.0.2) ... INFO –  Mona Jalal Jun 14 '13 at 1:12
add comment

2 Answers

I had the same problem. Looks like /usr/lib/python2.7/dist-packages/Quirks/quirkapplier.py reference xkit.xutils with this syntax : XKit.xutils (upper case at the begining)

I give a try to change it for a lower case syntax as I found some other references in other libraries with this syntax... It worked !

Hope it helped !

Regards. Django

share|improve this answer
add comment

try to run: sudo apt-get update -f , then sudo apt-get -f install. if its not working install aptitude by: sudo apt-get install aptitude and run sudo apt-get safe-upgrade. There is a solution of fixing broken packages here Package system broken - E: Sub-process /usr/bin/dpkg returned an error code (1) that may help

sudo dpkg --configure -a and sudo apt-get install -f

the problem of a broken package still exist the solution is to edit the dpkg status file manually.

$ sudo gedit /var/lib/dpkg/status (you can use vi or nano instead of gedit) Locate the corrupt package, and remove the whole block of information about it and save the file. I would personally recommend to everyone do fresh install instead of upgrading and make dedicated home folder so you will not lose any information reinstalling ubuntu. I had bad experience upgrading to new release.. notebook shut down while process and there were errors simular to urs.Bye

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.