Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm hoping this is a quick and simple fix and that I just need a fresh set of eyes. However, I'm fearful that it might actually be an error in the latest build of the rewrite module.

I have a .htaccess file that turns on the rewrite engine (I've made sure the module is enabled), creates some rewrite conditions, and finally a rewrite rule. Here's my .htaccess file for reference:

<IfModule mod_rewrite.c>
    RewriteEngine on

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule ^(.*)$ index.php?request=$1 [L,QSA,NC]

Now for the problem: if I go to it works fine. If I go to it works fine. However, if I go to it doesn't rewrite the request and I get a 404. I'm not sure what's going on here. I've used a rewrite rule tester and there doesn't appear to be any issues with my rewrite rule itself.

Again, this issue didn't manifest until after I upgraded to 12.10, at which point I know that Apache was updated.

Any thoughts? Has anyone else here experienced this? I know that two other people besides myself have experienced this here.

Thanks in advance for any help you can provide!

share|improve this question
Try to disable and enable it again with a2dismod mod_rewrite and a2enmod mod_rewrite. Restart apache afterwards: service apache2 restart. – OrangeTux Oct 21 '12 at 18:50
Still the same results. – CrowderSoup Oct 21 '12 at 21:06
up vote 1 down vote accepted

I was able to fix this issue. All I had to do was edit my virtual host and remove "Multiviews" from my options.


Options Indexes FollowSymLinks Multiviews


Options Indexes FollowSymLinks

And then it worked!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.