Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to disable uefi variables when booting from live usb. How do I do this?

I think that this is done through setting noefi, so if this is the right approach, how do I do this? I've tried from grub-edit like when temporarily setting nomodeset, but it didn't change anything.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Why do you need to disable EFI variables? There may be another way to accomplish your ultimate goal without messing with the EFI variables.

The noefi kernel option should indeed disable the EFI variables. If you've only tried it once, you might try it again; perhaps you mistyped it. I just tried on an Ubuntu 12.04 installation in VirtualBox, and noefi disabled the EFI variables support for me. (efibootmgr no longer worked and /sys/firmware/efi was missing.) You might also try placing it somewhere else amidst the kernel's options.

Another option is to boot using a BIOS-mode boot loader rather than an EFI-mode boot loader. If the USB device you're using is an Ubuntu installer, I believe it includes both types of boot loaders, so you should be able to use your firmware's boot option or possibly rEFInd 0.4.6 or later to select your boot mode. If you're using a custom USB flash drive, you'll need to install a BIOS version of GRUB manually.

A final option might be to remove the efivars kernel module, as in rmmod efivars, after booting. I tried to test this, but my test system uses a custom kernel with that module compiled in directly rather than as a module, so I can't guarantee that you'll be able to remove that module.

share|improve this answer

Either:

  1. Disable it from GRUB via the noefi kernel option
  2. or make your firmware (BIOS) boot the USB in Legacy mode.
  3. or use an ISO which is not EFI-compatible. Eg, Ubuntu32bit cannot boot in UEFI mode.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.