Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu 12.04 on my new Asus N56V Laptop.

I used to option to install it alogside with windows, and dedicated ~90Gb to it, but everytime I boot my computer, it loads Windows straight ahead, I don't really have the option to select between the both OS.

I've heard that it is some problem realated with UEFI, or somehing like that, but the problem is that I don't really understand a lot of Linux...

Thanks in advance for your help.

share|improve this question

3 Answers 3

I have ASUS N56VZ and I found the only way to switch is to press F2 on POST screen, navigate to Save and Exit, select the system you want to boot in "Boot override" section and hit Enter. By default I have Ubuntu and if I need "?dows - I select it like that. Both systems are in EFI mode, but GRUB doesn't allow me to boot "?dows.

share|improve this answer
  1. Run Boot-Repair from a liveCD or liveUSB
  2. Click the Recommended Repair button
  3. Reboot the computer. The GRUB menu should appear, with choice to boot either Windows or Ubuntu.

More information: https://help.ubuntu.com/community/UEFI

share|improve this answer

It's likely that Windows is booting in EFI mode but you installed Ubuntu in BIOS mode, or maybe vice-versa. Most UEFI computers provide relatively primitive options for switching between BIOS-mode and EFI-mode boots, although you can sometimes do so by pressing a key at boot time. (On my ASUS P8H77-I motherboard, it's F8.)

If you've got an EFI-mode Windows installation but you installed Ubuntu in BIOS mode, the better solution is to install an EFI-mode boot loader for Ubuntu. Replacing the grub-pc package with grub-efi should do the trick, except that to fully register the boot loader, Ubuntu has to be running in EFI mode, so you've got a chicken-and-the-egg problem. Since you've just installed, the easiest solution may be to re-install, but this time ensure that the installer is running in EFI mode. You can determine this by dropping to a shell and looking for the /sys/firmware/efi directory. If it's present, you booted in EFI mode; but if it's absent, you probably booted in BIOS mode. If you find that the installer is running in BIOS mode, reboot and look for those boot-time options (by using F8 or by adjusting your firmware options). Another way to gain better control of the boot process is by installing rEFInd, which is an EFI-mode boot manager that I maintain. Using its default settings, it should enable you to force an EFI-mode boot of the Ubuntu installer, provided the disc is inserted when you boot the computer. Version 0.4.6 can also switch to a BIOS-mode boot loader on many UEFI-based systems, although you must adjust the scanfor line in its refind.conf file. Using this ability, you might be able to chainload into your BIOS boot loader for Ubuntu. This might be acceptable to you, although IMHO it's simpler to boot directly in EFI mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.