Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a 4GB USB Memory, Serioux, Data Traveller. Today I wrote on it Linux Mint 13 Cinnamon edition, and now I want to format it.

I have tried to go to Disk Utility, select it and press "Format Drive", with the "Don't partititon" option, but when I click Format, and again , it gives me this message:

One or more partitions are busy on /dev/sdc

I have already tried to safely remove it and rebooted the system n times, but it is not working.

share|improve this question
up vote 7 down vote accepted

I believe it's being automounted. You can't format a mounted partition.

In Disk Utility click on "unmount" and then click "format".

"safely remove" will not let you format the USB stick, because it may actually unmount the drive and then tell the interface on the USB stick to power down. After selecting this option you can normally do nothing with the device until it is removed and inserted again (which will cause it to automount again...)

enter image description here

share|improve this answer
Thank you alot, my friend :) . It worked! – Iulian Oct 21 '12 at 15:14

I didn't find unmount option in my case so what you can do is

In ubuntu operating system:

Go to Disk utility:

You can use Delete partition ( - symbol ) to remove the partition and then create partition may be with FAT file system as it supports all the operating systems.

Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.