Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just upgraded to 12.10 and firefox doesn't work properly.

When I start it from the gnome shell nothing happens, however system monitor shows me two processes called 'firefox', the last one of which has memory field as N/A.

But when I just type in terminal firefox it starts and there is only one entity of firefox in the system monitor.

share|improve this question
    
This also affects gnome fallback. What is odd is that I made two installs. First a temporary test install, and I didn't get this bug. Second, on the proper install, I did. Perhaps it is because I never ran firefox under Unity on the first install. –  Alistair Buxton Nov 9 '12 at 2:20
    
I can't reproduce this with a clean firefox profile so I'm guessing webapps preview did something bad to my old profile that I copied over from 12.04 –  Alistair Buxton Nov 9 '12 at 2:29
add comment

1 Answer 1

up vote 4 down vote accepted

It turned out to be easy.

Just disable all unity add-ons in firefox:

  • Unity Desktop Integration
  • Unity Websites Integration

and it will work.

To do that be sure there is no firefoxes in the processes in the system monitor and launch firefox in the terminal with the command firefox.

share|improve this answer
    
Thanks --- it works. Should be reported as a bug in launchpad. Is there a bug opened about this? –  Rmano Jan 9 '13 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.