Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to give the new nouveau drivers a try. When I try a Ubuntu live distro, they work pretty flawlessly, but I don't seem to be able to use them correctly on my installed system. What I do is remove Nvidia drivers from the Additional drivers utility and reboot, but what I get is no 3D acceleration and low resolution on my monitor. What am I doing wrong? I wonder if I might have broken something when I messed up with grub trying to fix the infamous plymouth splash screen...

Thanks for your support

share|improve this question

4 Answers 4

Could it be that the nouveau drivers are blacklisted?

See if it something in /etc/modprobe.d/blacklist.conf or in one of the others in /etc/modprobe.d/

So, if there is, uninstall NVidia drivers, remove the blacklist nouveau line in the blacklist file(s) and reboot. Perhaps that would do the trick?

share|improve this answer
    
Nouveau drivers are blacklisted as long as nvidia drivers are installed. When i remove them, the blacklist nouveau lines disappear too, so that's not the case. Otherwise I wouldn't get any graphics at all, right? –  Zark Oct 21 '12 at 10:26
    
I assume you have searched around - but there was some info in this askubuntu.com/questions/12937/… –  bjaanes Oct 21 '12 at 10:32
    
I have. Nothing useful there. The point is: why do I get an ideal setup out of the box when I boot a live distro? It means there's something messed up in my system no matter if nvidia drivers are disabled. –  Zark Oct 21 '12 at 11:47

OP probably solved his problem but for future reference.

If you have tested various versions of nvidia drivers using jockey, it will just revert to whatever version of nvidia you have on your computer. You must continuously remove drivers on jockey until all versions are grayed out.

If you're stuck on command line, there is a command line jockey that can be started by jockey-text. Type jockey-text --help to see the list of options. You need to work with it as su (sudo) in order to disable/enable drivers.

Finally, you must remove xorg config file i.e. sudo rm /etc/X11/xorg.conf since nvidia settings in it will most likely clash with nouveau and can prevent X from starting.

share|improve this answer

This worked for me like charm, I got an oldie HP TX2000 and reinstalled several times because nothing seem to work, finally I found this:

sudo jockey-text -d xorg:nvidia_current

reference: how to revert to default video driver from nvidia driver?

share|improve this answer

Maybe instead of removing them try following (it worked superb on my Ubuntu, however I cannot guarantee it will also work for you). Download drivers from nVidia website. Install additional drivers in jockey, after reboot remove them, and without reboot install downloaded drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.