Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried using e4rat numerous times on two different computers following a couple of different guides, including the one on howtogeek. I have gotten up to the point every time where you add "single" to the end of the line starting with "linux" after pressing "e" in grub while Ubuntu is selected. I do this, and every time I get a black screen with a little cursor blinking in the upper left corner of the screen, and no matter how long I leave the computer alone (I once left it just sitting there for three hours straight) that is all that shows up. I do not get a login prompt. I am able to type things if I press alt+F1 and what I have typed is hidden when pressing alt+F2, and then shown again when I press alt+F1. I am following the guides exactly and I always get the same results. So if anyone can recommend an alternative to e4rat or a solution to this problem, that would be great!

I am running Ubuntu 12.10, if that helps.

Thanks for your help in advance!

share|improve this question
Your problem is in the execution of e4rat; adding "single" to the end of a grub line does not affect e4rat. Instead, it boots you into single-user mode, which is mostly used for system recovery (to verify that you are actually in single-user mode, type cd / && ls and press enter; if you get a list of files then you are in single-user mode; type reboot now to restart). See @memristor's answer on how to activate e4rat's collection mode. – InkBlend Oct 22 '12 at 23:53
up vote 4 down vote accepted

I think you are probably making a mistake in editing the kernel line after you press 'e'. I used this tutorial:

The first time you modify grub entry by pressing 'e'

you should see a line like this:

linux /boot/vmlinuzXXXXXXX-genric root=UUIDXXXXXXXXXXXXXXXX ro quiet splash vt.handoff=7

all you have to do is , click on the first word "linux" then press right arrow key -> to go to the last character 7. Then press space bar and enter following line:


When you make the addition the line should look like this:

linux /boot/vmlinuzXXXXXXX-genric root=UUIDXXXXXXXXXXXXXXXX ro quiet splash vt.handoff=7  init=/sbin/e4rat-collect

After this CTRL+X

If you follow the tutorial i gave above, you have to repeat this process of pressing 'e' one more time to modify same line as above. Above given tutorial says add 'single' instead of the line we added last time, this does not work. I used 'text' and then pressed CTRL+X. so second time my line looked like this:

linux /boot/vmlinuzXXXXXXX-genric root=UUIDXXXXXXXXXXXXXXXX ro quiet splash vt.handoff=7  text
share|improve this answer
Thank you so much! It worked this time. This was actually the guide I tried following initially and became frustrated with after it didn't work three times. – Josh Oct 23 '12 at 3:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.