Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i just upgraded my Ubuntu to 12.10 and i noticed that i get this message The location is not a folder whenever i try to access a mounted media (USB or even my other partitions). I am now unable to view content on my usb pendrive or other partitions.

already tried sudo apt-get remove exo-utils with no luck because it says it is not installed.

Can anyone help me?

UPDATE: this workaround seems to work for me

share|improve this question

marked as duplicate by Anwar Shah, Ringtail, con-f-use, Jorge Castro, Tom Brossman Oct 21 '12 at 19:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

What is the file-type? Did you upgrade or clean-install 11.10? This can happen when behavior for opening/copying a file or media is outdated / incorrect. Somewhere there is a path that is no longer correct. Possibly in Nautilus configuration. – david6 Oct 20 '12 at 23:47
I had a clean install on ubuntu 12.04. I now upgraded from it to 12.10 – psychok7 Oct 20 '12 at 23:50
Whoops, I meant 12.10. – david6 Oct 20 '12 at 23:55
Have you looked at this question? "The location is not a folder" error when opening files – Anwar Shah Oct 21 '12 at 13:54
Me too having the same issue.… – Vipin Ms Oct 21 '12 at 14:48

Are you trying to access the device through command line or script that worked with 12.04 and previous versions? They've changed the default mount point for USB devices so you might have to change the way you are doing things slightly to take it into account.

Previously USB devices were accessed at




From now on it looks like these devices will need to be accessed at




Yep, it's a pain, but I found that inserting $LOGNAME in my scripts seems to be taking care of it quickly and neatly. For example instead of:

cp -nv /var/cache/apt/archives/*.deb /media/${args[0]}/archives/$release/

change to:

cp -nv /var/cache/apt/archives/*.deb /media/$LOGNAME/${args[0]}/archives/$release/

To repair any permissions problems make sure you own the drive and all subdirectories open a terminal window with CtrlAltt and :

sudo chown -R username:username /media/username/volume

such as:

sudo chown -R psychock7:psychock7 /media/psychoc7/BACKUP\ HDD

see if you can cd into the directories or if you get any errors.

cd /media
cd psychock7
cd backup\ hdd
cd dirname


You can use


to get a directory listing, and use

ls -l

To get a long dirctory listing with extra information such as owner and access rights.

share|improve this answer
I am trying to acess it through nautilus/unity, not the terminal.. should i still do this? – psychok7 Oct 20 '12 at 23:53
No, it should already know where the mount point is. It seems like something is broken. You could plug your USB device in and have a look at the directory /media/username (your username) and see if it is mounting correctly though. If it's there, I don't see why nautilus should be having a problem. – fabricator4 Oct 21 '12 at 0:11
i got it working with SUDO... how can i change to make this the default behaviour? – psychok7 Oct 21 '12 at 0:24
It seems like a permissions problem. Do you only have one user? – fabricator4 Oct 21 '12 at 1:15
Yes only one user – psychok7 Oct 21 '12 at 1:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.