Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Karmic (9.10), my system time is currently off by 17 minutes, e.g. when I type date on the terminal I get Thu Jan 6 16:22:29 CST 2011 while the correct time is 16:05pm. I went through the standard time set and cannot fix this.

If it were off by a multiple of an hour I would blame timezone or daylight savings time settings, but 17 minutes, I have no idea.

Thanks

share|improve this question
    
What happens when you try to set the time? –  Stefano Palazzo Jan 6 '11 at 22:14
    
Nothing. I go through the process but the problem is unchanged. Under Administration->Time and Date, I have sync with Internet servers. –  recipriversexclusion Jan 6 '11 at 22:26

2 Answers 2

It may be your BIOS time. "Your computer has two timepieces; a battery-backed one that is always running (the hardware, BIOS, or CMOS clock), and another that is maintained by the operating system currently running on your computer (the system clock). The hardware clock is generally only used to set the system clock when your operating system boots, and then from that point until you reboot or turn off your system, the system clock is the one used to keep track of time."

share|improve this answer

This description of this bug might be related. The fix will be available in the 11.04 release in April. Ubuntu is supposed to sync with internet time servers by default so that everyone connected to the Internet should have a reasonably accurate clock.

Check if /etc/ntp.conf exists and is empty. If so, sudo rm the file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.