Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My details:

  • Thinkpad T410
  • GOBI 2000 WWAN
  • Ubuntu 12.10 with Gnome3

In Ubuntu 12.04, Debian Squeeze and Debian Wheezy my GOBI2000 works like a charm but in Ubuntu 12.10 the connection wizard doesn't show up.

I configured the card the normal way:

  • added thnkpad ppa
  • install gobi-loader-tp
  • copied firmware files to /lib/firmware/gobi/ (the same files work under debian)

The card is correctly recognized and my SIM is detected too. the only problem is when I try to setup a new connection the wizard doesn't start. simply nothing happens.

Any idea?

share|improve this question
    
Does it work if you just use the gobi-loader package from the Ubuntu repositories? –  carestad Oct 24 '12 at 23:24
add comment

3 Answers 3

I'm experiencing the same problem since upgrading to 12.10 but with a Huawei K3765 usb dongle.


I have a workaround. Hit Alt+F2 (or open a terminal) and run nm-connection-editor. Then you can go for the Mobile Broadband tab and add a new connection.

share|improve this answer
add comment

I have a Lenovo X201 which also has the Gobi 2000 and 12.10.

After I 1st installed Quantal a few days ago it actually picked up the card and connected using the BT Mobile sim I have installed.

Then I went to actually use it today the connection was no longer in the network applet dropdown....

I am assuming that the 1st time it worked was because the firmware had persisted from the previous windows install maybe....

Now I have it working again, what I did may help:

I had to add the thinkpad-extras ppa and install gobi-loader-tp.

In a terminal window (CTRL+ALT+T):

sudo add-apt-repository ppa:linrunner/thinkpad-extras
sudo apt-get update
sudo apt-get install gobi-loader-tp

I then downloaded and installed the lenovo driver package to a windows VM and got hold of the firmware files from the install.

Then had to play about with different firmwares from the choices until it worked.

One thing to be aware of is that you must have all 3 files (amss.mbn, apps.mbn, & UQCN.mbn) in the /lib/firmware/gobi dir. As mine for BT Mobile UK were split across 2 dirs (6 & UTMS).

Hope this helps.

share|improve this answer
add comment

Gobi2000 only suppoirt kernel 2.x .., so I jsut run it on Ubuntu 10.04 :P

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.