Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a current working setup of mpd -> alsa on ubuntu server 11.10. I now have an usb<>bluetooth adapter, with which i can see the to-be-paired device (logitech adapter) with hcitool scan. So far I haven't been able to pair/connect to the device from ubuntu server. From other device (cellphone) it does work.

I already tried fiddling on /etc/bluetooth/audio.conf and on /var/lib/bluetooth//trusted and pincodes without any success. I could already find orientation that applies to regular ubuntu (Desktop) but not something adequate for ubuntu server.

Ideally my setup would connect automatically (and keep connected) to the logitech adapter.

I understand that I'll have to define a virtual (??) alsa device to route the audio through the bluetooth connection, but so far my trouble is on getting the devices paired to begin with.

I appreciate any help. Thanks in advance.

share|improve this question
1  
For pairing this may help you: askubuntu.com/a/187100/3940, but I have no idea how to convince ALSA to stream audio to your BT. –  Takkat Oct 20 '12 at 18:42
    
Thanks. This was in the right direction. I had to add bluez-test-audio connect <xx:xx...> to really connect to the device, but it worked, as confirmed with hcitool con. Now I need to research sending my audio output to that device. I suppose I can manage to make mpd send directly to the device, not requiring alsa configuration. I'll post an update/guide when I get it working. –  h7r Oct 21 '12 at 10:13
    
A guide to sound to A2DP without pulseaudio would be rather cool indeed. I am looking forward to it - do write your own answer in case you figured it out :) –  Takkat Oct 21 '12 at 10:16
    
In the end I ended up using pulseaudio (I figured that with it was all a matter of getting dbus-x11 to run out of X and it simply worked). After an afternoon on freenode with some alsa folks I got all well with respect to bluetooth and understood that what should already be automatically recognized (bluetooth outout) by alsa was not. I tested configuring pulse and it was way simpler. –  h7r Oct 23 '12 at 20:21
    
Thanks for the feedback. I do believe this would still make a quite nice and helpful additional answer completing my earlier one with the bluetooth settings bits. Just saying... ;) –  Takkat Oct 23 '12 at 20:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.