Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop (Dell Inspiron 17R 5720) came with preinstalled Ubuntu 11.10. I removed it and installed 12.04. Now I can't find driver for wireless. Apparently, in 11.10 there was Broadcom-STA driver. But in 12.04 there is no additional drivers to install. I tried using:

sudo m-a a-i broadcom-sta

But building fails on 26%. How can I install driver?

According to lspci i got:

Broadcom Corporation Device 4365 (rev 01)
share|improve this question
    
Actually, i found a patch and applied it to wl_linux.c, now broadcom-sta compiles with make command. I installed resulted module (wl.ko). It loads and just does nothing. Wi-fi still doesn't work. I wonder whether I did something wrong or this is wrong driver (strange though, in OEM 11.10 in list of 3rd party drivers there was Broadcom STA (although it was not activated)). –  NilPointer Oct 21 '12 at 4:15

1 Answer 1

up vote 0 down vote accepted

Looks like I've reached end of that long maze on my own. I've installed modified deb from here:

how-do-i-install-bcm43142-wireless-drivers-for-dell-vostro-3460-3560

And loaded kernel module "wl". After that, Wi-Fi started to work. I added wl to autoload at boot time... Anyway, looks like problem is solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.