Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a 'show desktop' shortcut to work, so I'm using 'hide all windows' shortcut to show the desktop. But after it hides the windows, I can no longer alt-tab through them, and I have to manually click on the unity bar to get back.

I would like alt-tab to switch through all of the applications open in my current workspace (including hidden ones)

share|improve this question
up vote 1 down vote accepted

From what I can infer, I think you have configured in such a way that minimized windows will not show in the application switcher.

Install compizconfig-settings-manager Install compizconfig-settings-manager and go to Ubuntu Unity plugin:

Ubuntu unity plugin

Navigate to switcher tab and check the option Show minimized windows in switcher.

Alt-tab setting

share|improve this answer
    
Wow, compizconfig can do anything! – StuartHa Oct 22 '12 at 4:53
    
This entry doesn't appear in CCSM in 15.04/Vivid Vervet, at least on my installation. Are there any alternatives to using CCSM? Is there a settings file or other power user tweak that controls this setting? (I've tried the "Window Manager Tweaks" utility mentioned in ponsfrilus's answer, the utility doesn't start on my system.) I want to exclude minimized windows from the switcher, similar to OSX/Mac behavior -- this is not the case on my system, all windows are shown, minimized or not. – Inactivist Jan 10 at 16:50

Same possibility with Windows Manager Tweaks, as in the picture bellow.

Windows Manager Tweaks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.