Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I think my system is not allocating enough RAM to WINE applications . I am using WINE to play games but they are loading slowly and RAM usage is normal. So how can I improve reserve memory of WINE?

enter image description here

share|improve this question

1 Answer 1

up vote 3 down vote accepted

RAM:
I don't think there is much you can do as wine takes what it needs. As it is 32bit the upper limit is 4Gb. Then there is a 2Gb (sometimes 3Gb) limit for RAM per application.

Video RAM (VRAM):
You can allow more VRAM by editing the wine registy:

  1. wine regedit
  2. go to:
    HKEY_CURRENT_USER → Software → Wine → Direct3D → VideoMemorySize
    and set the value to a higher one. The default seems to be 64Mb.
    If you see no such key, create it (right-click on Direct3D, select New then String Value and name it VideoMemorySize).

More registry information: useful registry keys from wiki.winehq.org.

This detailed memory management page from the wine developer notes might give more clues but it is quite technical.

share|improve this answer
    
but i am not having that option. –  AgentCool Oct 20 '12 at 17:03
    
Try adding the Direct3D folder, then create the key. Then close all wine applications so the wine server does not run. What wine version are you running? (wine --version) –  rosch Oct 20 '12 at 17:41
    
Did adding the folder work? –  rosch Oct 24 '12 at 19:45
1  
amigo I'm in home on vacation . doing this from mobile . I'll try and let you know . –  AgentCool Oct 25 '12 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.