Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my 12.04 to 12.10 and after restart I can't do anything. I can just use the console (Ctrl+Alt+T). I can't move windows, there is no window bar, no top panel, no unity launcher.

What I should do?

Any help would be greatly appreciated.

My PCs properties:
Intel® Pentium(R) CPU G840 @ 2.80GHz × 2
GeForce GTS 450/PCIe/SSE2

share|improve this question
    
Can you edit your question and provide us with some info about your system. –  Chris Carter Oct 20 '12 at 15:47
    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Oct 23 '12 at 1:21
add comment

closed as off topic by Jorge Castro, Ringtail, devav2, Anwar Shah, Stephen Myall Oct 23 '12 at 8:11

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I think this is also what I am experiencing... For me the problem is that the graphics driver claims to support OpenGL and GLX but lacks important features for Unity. Due to some changes in Unity it won't fall back to slow mode automatically. Try to add the following file:

# /etc/X11/Xsession.d/99try_slow_mode
export LIBGL_ALWAYS_SOFTWARE=1

Then reboot and see if it works. This essentially forces all applications to fall back to software 3D rasterizer which is slow. I think they are currently trying to add some smarter fallback and I'd like to see that it gets fixed.

It also looks like there is currently nothing one could do to disable some effects in Unity so it will work with implementations of older graphics drivers.

To revert back simply delete the file and reboot.

Amendment: Just in case someone wants to collect this, my GPU is AMD Mobility Radeon 7500 [RV200]...

share|improve this answer
    
Thanks for prompt reply! I am quite new in Ubuntu actually. I dont know what I should do, which file I can add? I suppose that this is not command –  madox2 Oct 20 '12 at 16:18
    
I found the solution. I just install my graphics(which was not after upgrade) with command: apt-get install nvidia-current Some of settings are gone(such as window transparency, shortcuts) so have to customize my ubuntu again. Anyway, thanks for help! –  madox2 Oct 20 '12 at 17:12
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.