Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
no windows 7 entry in grub after installing ubuntu

i just install Ubuntu 12.10 along side Windows 7.When booting it goes straight to ubuntu and skip grub.This problem occured since 12.04 on 11.10 everything went just fine. I run update-grub and Windows 7 is not listed.

Extra: My partition sda2 is ext4 Ubuntu 12.10 (46gb) sda3 is swap Swap File (4gb) sda5 is ntfs Windows 7 (50gb) sda6 is ntfs Everything (400gb)

share|improve this question
add comment

marked as duplicate by Tom Brossman, con-f-use, Jorge Castro, RolandiXor, Mitch Oct 22 '12 at 19:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

try opening a terminal (either windows-key, type terminal, or ctrl+alt+T) and doing a:

sudo update-grub

fixed it for me...

Failing that, you might need to reinstall Grub completely. There's some instructions here

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

I've used boot-repair in the past, but it looks like it might be as simple as just doing a

sudo grub-install /dev/sda

the important thing is to use the device (sda) not the partition (eg sda6)

share|improve this answer
    
already tried that...still doesnt work –  user99216 Oct 21 '12 at 8:41
    
any luck with the grub-install option instead? –  hwjp Oct 23 '12 at 10:46
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.