Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Getting the following error when attempting to install the virtualbox kernel modules :

------------------------------
Deleting module version: 4.1.18
completely from the DKMS tree.
------------------------------
Done.
Loading new virtualbox-4.1.18 DKMS files...
Building only for 3.5.0-17-generic
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

I tried installing the linux-source package, but not sure how ubuntu handles kernel sources and headers. Any ideas on how to do this from an Ubuntu standpoint?

share|improve this question

4 Answers 4

You need the kernel header as well. Based on your output, sudo apt-get install kernel-headers-3.5.0-17-generic should do it. On the guest VM, either autorun the ISO image or sudo sh ./VBoxLinuxAdditions.run from the shell prompt should work. Appears this is a known problem with the latest 12.10 release.

share|improve this answer

My Virtual Box told me that the kernel drivers were not installed. I ran apt-get remove virtualbox-dkms to remove the drivers and then re-installed them (apt-get install virtualbox-dkms) which rebuilt the drivers and I was able to run virtualbox with no problems

share|improve this answer

An other way:

apt-get install linux-headers-`uname -r`
dpkg-reconfigure virtualbox-4.2

The normal way:

/etc/init.d/vboxdrv setup
share|improve this answer

Didn't work for me. Solved it by running:

sudo synaptic

Search for 'dkms' and (re)install the one for virtualBox and hit the 'Apply' button. The output should say that virtualbox kernel drivers are up and running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.