Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

One day when I was trying to connect with wireless I found it didn't work.It said:

wireless is disabled by hardware switch

I'd found some questions similar to mine, so I tried some suggestion as following:

~$ rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes

so I typed:

sudo rfkill unblock all

Then I got:

rfkill list all
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

but the wireless still didn't work. I'm sure wireless lan is enabled in BIOS and the hardware switch is turned on (a small switch on the front side of my laptop). Also Fn+F3 or Fn+F5 didn't work.

I was in Ubuntu 12.04 and I thought it might be a system problem, but when I started my laptop with Ubuntu 12.10 installation disk, this problem still exits.

share|improve this question

3 Answers 3

look at Hard blocked: yes it seems at that time maybe you forgot about the hard switch. may be it was turned off ?

I had the same problem wireless is disabled by hardware switch and this happens to me every time when I am in windows and I disable the wireless using the hard-switch. and when I reboot to Ubuntu, I see that I can't enable my wireless and the error is wireless is disabled by hardware switch.

Then I found the command sudo rfkill unblock all which solved the problem. However I had to type it a couple of times before the command had enabled my wireless switch.

So what I will do is, go to windows, disable the wireless using the hard switch and then enable it again using the hard-switch while you are still in windows. then reboot to Ubuntu to see if it has worked. if not then use the command and type 3-4 times in the same terminal.

share|improve this answer

Simple just check the wireless in your BIOS where if its set to off then change the value to on. It worked for me as am using Lenovo Thinkpad Edge laptop.

share|improve this answer

I had the same problem with my Dell XPS 15 9530. I tried different Linux distros (Debian GNOME, Debian with Xfce, Ubuntu Workstation) and the problem never occurred. Then, in a new installation of Ubuntu Server + Openbox, I suddenly found my wireless disabled (hardware switch off):

With sudo rfkill list I received the following status:

phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

sudo rfkill unblock all didn't help.

Then I searched and tried several suggestions without success:

  1. There was no BIOS option that could help.
  2. Pressing the function keys on my keyboard didn't help.
  3. Loading/unloading modules didn't help.

Then I thought, if my operating system fights against me and I have no idea what could be wrong, I'll simply try to weaken it, put it in sleep mode and press the function key again (...). Indeed, this workaround did it:

On my Dell XPS 15 keyboard, there is a key with a wireless antenna symbol. (I have a German keyboard, where the function key for wireless on/off is not F2 but a separate key next to F12)

  1. Put the notebook in sleep mode using sudo pm-suspend
  2. Reactivate the notebook by pressing the power button.
  3. Now press the correct function key(s) for removing the hardware lock during wake-up.

This doesn't work when the notebook is in sleep mode, you need to press the function key DURING the wake-up process.

I am not a Linux specialist and have no reasonable explanation for this technical workaround, so I apologize if this doesn't make a lot of sense. However it works (and in my case is required after every reboot). If someone has a more objective explanation why this worked, I'd appreciate your comment. I still would like to know what went wrong. I hope this trick helps in some cases.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.