Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop that I have used for many years, and it has had Ubuntu on it since maybe version 8.04 or so.

This morning I upgraded from 12.04 to 12.10. The upgrade process went perfectly smoothly until it rebooted.

Now, when the computer boots, it goes into some kind of memory test, and never reaches GRUB.

On the one hand, it would seem that this is a hardware memory failure, and nothing to do with the operating system. On the other hand, I can't shake the feeling that it seems the timing is more than just coincidental. If my memory were as cataclysmically faulty as it now appears, I'm sure I would have seen some problems before today. In my experience, memory tends to start failing bit by bit, not all at once like this.

Is it just a horrible coincidence, or is there anything about an OS that can impact or trigger a problem like I'm seeing?

enter image description here

I've tried rebooting, but it will not get past the memory test. The memory test itself seems to go on indefinitely. It's been over 24 hours and it's still going.

share|improve this question

closed as too localized by fossfreedom Oct 24 '12 at 11:53

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Memory checks can take very long. Please verify whether or not it keeps repeating the check, or actually manages to finish it. Also: If possible, try to replace the RAM to see whether it works then. It does look like a hardware failure after all. – user98085 Oct 20 '12 at 11:08
@FEichinger: I can already tell you it's not repeating anything. The errors are so numerous that it has not yet fully completed the current set of tests once. – Questioner Oct 20 '12 at 11:10
That's a good sign at least. While it means it'll take long to finish, it doesn't just jump back to the start. First, I'd try just letting it run until its finished and if that doesn't work, get new hardware. Finding the reason is gonna be slightly hard, though ... Could be anything from a corrupt file loaded into the memory to plain uninduced hardware failure. – user98085 Oct 20 '12 at 11:14
I too had faulty memory some years back. Initially I didn't notice it at all, Windows XP crashed occasionally, Linux never. I started to become suspicous and ran memtest and I discovered the error. It's possible that your RAM had errors before, but you didn't notice it either. I'd say it's hardly possible for software to destroy RAM. – phoibos Oct 20 '12 at 11:36
OP flagged for closure - they have bought a new laptop, thus this Q is now too-localised. – fossfreedom Oct 24 '12 at 11:53

Two interrelated bu different things come to my mind:

  1. As the memory test shows your memory is faulty. Memory faults might cause random crashes.

  2. The ubuntu grub file grub.cfg was altered during installation. One normally expects a grub boot menu during the boot process and chooses the relevant operating system if more than one os exists. Since you cannot boot to ubuntu, then u have one option: use a live cd to correct the grub.cfg file manually (not recommended) or "sudo update-grub2" command. Then, you should normally boot into ubuntu. Your system might crash due to memory faults randomly.

share|improve this answer

You could also try unseating and then reseating the memory itself - thermal socket creep could be an issue, although it's a long shot. See

share|improve this answer

The issue sounds like a hardware problem to me and you can try to disconnect the HDD and you will probably see the system still failing at the memory test. I have a few questions and suggestions:

Can you somehow bypass this my hitting ESCAPE or ENTER to get past the test?

Can you enter the BIOS? If so, try to reset it to the fail-safe configuration.

Something might be conflicting with BIOS RAM detection so try MemTest86. You can get it, from their site and make a bootable Cd or a floppy. Twelve to twenty four hours of testing proves your memory good or bad. Or you could try a process of elimination by removing all but 1 stick of Ram and see if it will post then - IF not remove that one and try another one - IF one of them works then go into BIos and check the Voltage and timing settings and save. Turn off the system and try the other sticks adding one at a time. - It doesn't need all of them to fail in order to stop posting so it may just be any one of the sticks or it could be the settings

share|improve this answer
Thanks for the suggestions. A couple of points: There is only one RAM stick. I tried various options in the interface to try and bypass the test, but nothing would work. At this point now I'm going to let it run for as long as it wants and see if it ever does come to an end or just repeats. So far it's still running the same test. – Questioner Oct 20 '12 at 17:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.