Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried downloading Ubuntu Server 12.04.1 LTS 32bit but it fails at 156.790kb image file at start of download says 645mb it will only download 156.790kb then finishes. where can I download this image to receive the full download? I have tried to download it in different browsers same problem.

share|improve this question

Open this as a text file.

You will able to see all links. Maybe you will be able to use them. Try each one, one by one.

share|improve this answer

I can download the Ubuntu Server 12.04.1-i386 image just fine, but it appears to be a bad ISO. No matter which computer I use to download the image I am unable to read it. I am also unable to find a link back to the previous version ISO (12.04 without the .1).

I've tried this using Mac OS X v10.8.2 (Mt Lion), Windows XP SP2, and VMware ESX.

UPDATE: Also, the amd64 appears to have the same problem. Perhaps it's the mirror that the web site is pointing me to by default that has the bad images? I guess I'll start trying links from Xiokang's response...

UPDATE: Doesn't seem to matter which mirror I use. The MD5 checksum verifies that the image I'm downloading matches what Canonical thinks I should have. However, I still can't do anything useful with the images, nor can VMware read it.


  • ubuntu-12.04.1-server-i386.iso = 3daaa312833a7da1e85e2a02787e4b66
  • ubuntu-12.04.1-server-amd64.iso = a8c667e871f48f3a662f3fbf1c3ddb17

These match what Canonical has listed here.

SOLUTION: Ok, apparently these images are SUPPOSED to be broken, as they are using some kind of hybrid multi session layout or something. OS X is not able to verify or read these images without extra help from some shell commands. Also, VMware, when using EFI mode, will not be able to boot from the images as well. Apparently these images are intended for applications (like Roxio Toast) to burn directly to physical optical media. Hence why they have the unusual hybrid configuration, which works fine when being read from a CD. Follow the instructions for creating a USB thumbstick in order to use the images on a Mac. For VMware, make sure that your ESX virtual machine is set to use BIOS rather than EFI.

share|improve this answer

first of all, if you can download torrents which is the preferred way to download big files then use this

if you don't want torrents. Then take my advice: Never download big files using the default downloader of the browser, they are so bad, do not support stopping and resuming, and you will often end up with a corrupted image. Use an independent download manager. If you're on windows use FDM, if you're on Linux download uget.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.