Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the Tizen SDK 2.0 which uses Eclipse 3.7.1 as an IDE on Ubuntu 12.10 64bit. When trying to create a Tizen Web Project I got the following error message from Eclipse:

Unhandled event loop exception No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]

The problem is that Eclipse is configured to use Xulrunner as a headless browser inside the IDE. Xulrunner is not in the repositories for Ubuntu 12.10 any more, therefore Eclipse is not able to find the libraries.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The current Tizen IDE is based on Eclipse 3.7.1, and Eclipse SWT faq page page lists the required Xulrunner versions for Eclipse:

Eclipse 3.7.x/4.1.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x (but not 2.x), WebKitGTK+ 1.2.x and newer

There are two solutions to this problem:

  1. Manually install XULRunner and install it
  2. Configure Eclipse to use Webkit instead of XULRunner

Manual installation of XULRunner
A compatible version of - XULRunner 3.6.x - can be downloaded from Mozilla's ftp server at http://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/3.6.28/runtimes/

Extract the xulrunner folder into your home directory, e.g. /home/username/opt/xulrunner.

Configure Eclipse to look for XULRunner in that folder by adding the following line to the tizen-sdk/ide/eclipse.ini file:

-Dorg.eclipse.swt.browser.XULRunnerPath=/home/raju/opt/xulrunner

Restart Eclipse and everything should work as expected.

Use Webkit instead of XULRunner
Install the package libwebkitgtk-1.0-0 and configured Eclipse / TizenIDE to use Webkit instead of Xulrunner by adding this line to the eclipse.ini:

-Dorg.eclipse.swt.browser.DefaultType=webkit

Restart Eclipse and you are ready to code.

share|improve this answer
    
This question and answer were a life-saver. Thank you! –  Andrew Nov 9 '12 at 20:00
    
is it possible to use another version than libwebkitgtk-1 ? for example, libwebkitgtk-3 is installed by default in Ubuntu –  ttoine Jun 13 '13 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.