Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded from 12.04 to 12.10 on my desktop. My bluetooth dongle does not get detected after the upgrade, which was working fine before.

I tried another dongle of another brand and that works. But I want to use the old one as that is good quality one that comes with Logitech DiNovo keyboard.

share|improve this question
up vote 3 down vote accepted

I have the DiNovo Cordless Desktop too, the old version (LZ845AG).

The problem reside in the dual mode functionality of the USB dongle. It is a full btusb dongle, but it has a second operating mode: it works as a (non-bluetooth) HID device.

This is neccessary if, for example, you want to enter BIOS with the keyboard. There is no bluetooth stack available at BIOS stage, so the dongle works in HID mode. Otherwise you could not use the keyboard in BIOS / DOS / any non-bluetooth environment, so the dual mode does make sense.

However, full functionality is somewhat broken (again) in 12.10., depending on your setup. I have tested 3 choices so far:

1.) You are working on a non-dualboot machine: No problem. Just bind the keyboard / mediapad / mouse once. Re-insert the stick if it does not work. Re-insert the stick while pressing the red button on the stick if it still does not work (this will force bluetooth mode manually). When the bluetooth icon finally appears on screen (top bar, left to the time clock): Press the red buttons one the devices, then use the bluetooth icon to add the devices, one by one.

2.) You are using a different usb dongle with the hardware: Works too, see above, but you need additional software on dual boot machines, e.g. for Windows. May be tricky there, but works for Ubuntu just fine.

3.) You have a dual boot machine and want to use the original usb dongle as well as the standard Logitech Windows software: At least with my DiNovo (old version) the problem is now that you are forced to re-bind all of the devices everytime you switch operating systems. There are rumours the newer DiNovo does not have this problem, but I did not find a way around it with my old DiNovo so far. Very sad, as the DiNovo is not the cheapest keyboard / mouse combo around at USD $180.

So everytime you switch, enjoy the hen and egg problem: Try to add keybard and mouse in Ubuntu without having keyboard nor mouse. Good luck. ;)

On older Ubuntu versions you could circumvent this by uninstalling the Logitech software in Windows and let the DiNovo run in HID mode under windows, and in Bluetooth mode in Ubuntu. For some reason, this does not work in 12.10. anymore.

share|improve this answer

Solution is as follows.

  1. Keep the red button under the dongle pressed, while inserting the dongle into the USB port. The dongle is then recognised instantly. (did'nt need to do that on 12.04)

  2. Pair you keyboard, so the keyboard is now attached to your dongle.

  3. Reboot and you can even goto BIOS using your keyboard, however you will not see the dongle again when system boots. However your keyboard is still working.

share|improve this answer

I had the same problem. Killing and starting bluetooh again solved my problem without installing/editing anything. Apply these commands in a terminal:

sudo killall bluetoothd && sudo bluetoothd
share|improve this answer
This did not work for me. The problem I am facing is that my dongle is not getting detected at all. Its detected in POST during boot though. – vikas112 Oct 20 '12 at 10:45

There is some problems related to bluetooth... maybe this post can help:

Bluetooth not working Ubuntu 12.04 Fujitsu P771 Foxconn /Hon-hai 0489:e031

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.