Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded from 12.04 LTS. The upgrade went fine until the moment, while still installing packages, all the unity taskbars and window frames went away. I could do nothing more but observe the installation progress (the only app I had running was Chrome but it hanged, and because of lack of taskbars I couldn't restart it). But installation finished successfully and it asked for reboot. After rebooting, it booted into some low-res mode, displayed a message box that it can't detect my video drivers correctly and apparently I couldn't do anything - there were no reaction to mouse nor keyboard. Oh.

However, I noticed in the logs that while booting, it started that bumblebee optimus thing. I had optimus disabled, so I went to bios and enabled it. I also managed to get into text console (framebuffer) and changed grub settings to boot straight into text mode. Now I tried starting X server manually (startx) and it showed me the high-res desktop, started two apps that I had in autostart, mouse and keyboard were fine. But no taskbars and no window frames. The screen resolution was fine (1920x1080) and looked like nvidia drivers booted properly.

The next thing I tried was uninstalling nvidia-current-updates, uninstalling bumblebee-nvidia, and setting xorg.conf driver to vesa and then nouveau. In both cases, I got low-res desktop with no damn taskbars nor frames. So then I installed only nvidia-current-updates (installation went fine) - I got back nvidia drivers working (logs and splash screen confirmed it), high-res desktop, but of course still with no unity taskbars.

The last thing I tried was removing .compiz and .config/compiz directories from my home folder, as I read such advice on the Internet. Didn't work. Also creating a fresh user account and starting x from there - showed only empty desktop, no taskbars.

Now I'm stuck. Seems the damn thing doesn't work at all. I have to get it somehow working by Monday. Please help me what can I do to:

  1. fix it
  2. debug it and fix it
  3. workaround it, at least so I can make some work while still trying to fix it later - I was thinking of installing a different graphic shell, but I don't know which are usable with ubuntu
  4. downgrade to ubuntu 12.04 (but really don't want to do that)

My hardware: Dell Precision m4600 i7 Core Quad, 24 GB RAM nVidia quadro 1000M

Ubuntu installed kernel 3.5.0-17.

Thanks a lot, Piotr

share|improve this question
Still not working? – Braiam Jan 23 '14 at 13:19
It works, and the funny thing was, it fixed itself after reinstalling the stable version of nvidia driver once again. Now I'm on 13.10 and upgrading from 13.04 was smooth. However, I've still got some issues with attaching external monitors/projectors when using Intel card, which forces me to be on Nvidia all the time and fans are almost never off because of this. – Piotr Kolaczkowski Jan 24 '14 at 13:58

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the commands below.

sudo apt-get autoremove fglrx --purge


sudo reboot
share|improve this answer

I have the nearly exact same hardware: Dell Precision m4600 i7 Core Quad, 8 GB RAM, nVidia quadro 1000M

I actually was able to perform the distribution upgrade from 12.04 to 12.10 without significant incident.

However, after futzing around with the new unity, I screwed a few things up and decided to start with a fresh install of 12.10 because I tend to gather too much cruft anyway.

After a two failed attempts with the downloaded versions of "Additional Drivers", I realized they had added the tab to "Software Sources" to apply proprietary drivers.

However, when trying to actually apply any of the nvidia drivers I would reboot to a diminished resolution screen without unity trim.

I just got it to work however, and I believe it has to do with info I gleaned from the NVidiaManual:

That page alludes to the need for build-essentials and the linux-headers-XXX-generic. Also restricted headers, but don't actually see anything in that package to affect anything.

sudo apt-get install build-essential linux-headers-`uname -r`

Once I installed those two bundles of things... I went back to software sources and was able to apply the "nvidia-current" driver and reboot with fancy proprietary drivers...

So much prettier than the default Nouveau driver.

share|improve this answer

This looks similar to this one: Unity Dash and top toolbar won't open after updating to 12.10.

If removing the flgrx wont fix it, try removing the nvidia if you have it installed. It fixed mine after removing any nvidia.

share|improve this answer

You can have several desktop types installed. I installed KDE and so at least it allows me to use my computer. Soon hopefully someone will find a solution and I can try Unity 3D but at least this way I have a computer.

Open a terminal console and enter the following command to install Kde-Plasma-Desktop:

sudo apt-get install kde-plasma-desktop

If it asks you which default desktop you want to use just select KDE (or KDM)

Then upon login choose the appropriate desktop you want to use (there's an arrow or something you can press to get the list of available desktops).

share|improve this answer

I was stuck in that situation too.

My solution was to install jockey-kde and activate the first license-free Xorg driver. The proprietary drivers always returned some error for some reason... Some users claim it to be dangerous to do it, so do it at your own risk. I had nothing to lose, so...

Once I got my unity back, I tried to reinstall the nvidia-current driver, but it messed up the unity again... Activated the Xorg driver through jockey-kde and all was back to normal again.

share|improve this answer

protected by Braiam Jan 23 '14 at 13:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.