Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to login into my Ubuntu VM from my username, it goes briefly to a black screen and then back to the login screen. I can login as "guest" though.

I can login with just the terminal with ctrl-alt-f1. I have checked disk usage there and it is not the issue. Oddly, in this terminal, some of my keys are goofy. For instance, hitting the "/" results in a "-" being typed while typing ":", "'", "{", etc results in accented vowels. I don't understand this at all--perhaps some settings somewhere really got goofed up.

I was able to login just last night and use my VM. Recently today, my computer performed some windows updates (I have windows 7) and there is a chance that they may have been the cause. I have tried creating a new VM through the vdi we were given (for a class) and the same exact problem occurs again!

Please help! Thanks.

share|improve this question
    
Btw, I am using Ubuntu 11.10 if it matters. Any thoughts on how to fix would be very much appreciated! –  Peter Oct 20 '12 at 13:47

2 Answers 2

I had the same problem; Fortunately the answer by Ames in the link below helped me fix it: Can't Log Into Ubuntu 12.04

Quote: I ran into the same issue. The problem was in the user .XAuthority file, permission was owned by the root user. I changed the file permission and was able to log back in.

Using ctrl+alt+F1, I logged into my account, then changed the ownership of the file ".Xauthority" by typing the command below in terminal: (My username is masoud, and since it was the first user I created in Ubuntu, a group named masoud was also created)

sudo chown masoud:masoud /home/masoud/.Xauthority

The first "masoud" is the username and the second one is its group. The dot before the file name implies it's hidden.

share|improve this answer

I checked the error log in .xsession-errors in my home directory and found that there was an error related to ssh-agent in my .profile. That used to work just fine until I upgraded my VirtualBox guest additions to 4.2.12. In any case, removing those lines got me back into my VM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.