Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo ThinkPad x230 that I just purchased and installed Ubuntu 12.10 on it. There is no sound, how do I fix it?

I checked that my volume is not muted. I also tried checking in alsamixer and it looks like it doesn't see my sound card.

share|improve this question
1  
I just installed the 3.6.2 kernel to see if it would help, and I had sound for like the first 15 seconds after boot, but after that the sound was gone (even after reboot) –  Another Googler Oct 20 '12 at 15:03

5 Answers 5

up vote 2 down vote accepted

On my X230 Tablet disabling "auto-mute" in alsa-mixer fixes the problem, that there is no sound after one sound was played. Try to plug in headphones and check if there is sound, then it could be the same problem.

share|improve this answer
    
Thank you, disabling auto mute worked for me too. I'm not sure how to submit a bug, but this seems like one worth submitting. –  Another Googler Oct 22 '12 at 3:36

If none of the above works try using

alsactl init

then play something.

share|improve this answer

I've had the same problem with a similar model thinkpad (x200t) but the solution was easier than I first thought.

I had found that I had pressed the mute button on the keyboard which despite what I tried to do using software wise would not work again until I pressed the the volume up/down key on the keyboard then the sound was back again.

So, I learnt that I can mute the sound using the hardware button, but cannot turn the sound back on again using the software mixer nor by pressing the mute button again. Only by using the hardware volume buttons on the keyboard.

share|improve this answer

I temporarily solved that problem on my x230.

  1. Switch to terminal mode via Ctrl+Alt+F1 and log in.
  2. Stop the display manager LightDM with: sudo service lightdm stop
  3. Reload ALSA with: sudo alsa reload
  4. Then restart LightDM with: sudo service lightdm start
share|improve this answer

Workaround is to select the Multistream mode from Realtek control panel, Device advanced settings this works for me.

the solution is stolen from this link: http://forums.lenovo.com/t5/X-Series-ThinkPad-Laptops/X230-No-Sound-Until-I-Go-To-Settings-To-Play-Sound/td-p/910343

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.