Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I somewhat recently starting running Ubuntu 12.04 on my Macbook Pro 5-5 with minimal problems. The main issue I was having was I couldn't control the screen brightness, which after searching, I realized was a common problem. I tried to fix it by opening

sudo gedit /etc/X11/xorg.conf     

and adding

"RegistryDwords" "EnableBrightnessControl=1"    

When I rebooted, the screen got stuck at the Ubuntu Screen with the 5 orange dots. I tried searching for solutions, but nothing has worked. I'm guessing I messed up the xorg.conf because after booting to the Terminal and entering startx it shows a fatal error of no screens detected. I tried using

sudo dpkg-reconfigure xserver-xorg

but that didn't work, so then I tried using

sudo apt-get remove xserver-xorg

then reinstalling it with

sudo apt-get install xserver-xorg

and rebooted, but it still gets stuck at the same screen. I'm new to Ubuntu and Linux in general, so I'm not sure what I messed up or how to fix it. I know I can always reinstall Ubuntu, but I'm trying to fix it without having to do that. Thanks!

EDIT: I have a NVIDIA GeForce 9400M graphics card and am using additional drivers that I install when I installed Ubuntu.

share|improve this question

closed as too localized by Jorge Castro, RolandiXor, Mitch, Takkat, John S Gruber Oct 22 '12 at 21:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try to remove the xorg.conf and regenerate it. Add some info to your question like, what is the model of the graphics card and what driver you use (additional or open source). You can see that with this command in terminal lspci -nnk | grep -iA2 vga and I am sure there is a more painless way to fix your brightness issue rather than invoking the xorg.conf file. –  NikTh Oct 20 '12 at 2:39
    
I have NVIDIA GeForce 9400M graphics card, and I'm using additional drivers. Yeah, I thought there should be a pretty easy way to do that too, but that was the only thing I could find that people had success with. What command should I use to remove and regenerate xorg.conf? –  user99044 Oct 20 '12 at 16:40
    
For nvidia driver , the command is 1) Remove sudo rm /etc/X11/xorg.conf 2) Regenerate sudo nvidia-xconfig –  NikTh Oct 20 '12 at 17:11
    
Perfect! That worked. I must have just messed that up when trying to fix the brightness issue. Thanks for all of your help! –  user99044 Oct 22 '12 at 1:30