Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I want to listen to streaming audio from Ubuntu using headset (Bose Bluetooth Headset Series 2). Although Bluetooth connection is established, I haven't been able to hear anything via the headset. How can I work this around in general (I know this might sound brutal but I don't have much knowledge in audio setting on linux) ?

When I use my other Bluetooth headset BlueAnt Q2 (http://www.myblueant.com/products/headsets/q2/index.php) streaming is going. In "Hardware" tab on sound setting panel (not sure how it's officially called but see the image below) shows my headset.

enter image description here

However, Bose one never appears on the same window while it's connected via Bluetooth, except for a few seconds after I manually disconnect the headset (this moment is snapshotted as the image below. When it's connected the Bose BT2 thing is never shown. Btw, with Android phone this headset works just fine).

enter image description here

Bose' manual indicates that

Make sure the device supports A2DP audio streaming.

So I tried to figure out if A2DP is enabled on my Ubuntu (referring to Can I use my computer as an A2DP receiver?), finding that it's probably available as the result below shows:

$ sdptool search --bdaddr local a2snk
Searching for a2snk on FF:FF:FF:00:00:00 ...
Service Name: Audio Sink
Service RecHandle: 0x10005
Service Class ID List:
  "Audio Sink" (0x110b)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 25
  "AVDTP" (0x0019)
    uint16: 0x102
Profile Descriptor List:
  "Advanced Audio" (0x110d)
    Version: 0x0102
share|improve this question

marked as duplicate by user68186, Kevin Bowen, minerz029, Eric Carvalho, blade19899 Dec 17 '13 at 12:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Did you try to remove the BOSE headset from known devices in the Bluetooth settings, then put it in pairing mode to pair and add it again to your devices? –  Takkat Oct 20 '12 at 9:26
    
@Takkat I'm sure I did on Ubuntu side but am not sure if I did on headset. I'll try –  IsaacS Oct 21 '12 at 7:24
    
Install pavucontrol, execute (PulseAudioVolumeControl),choose configuration tab once your bluetooth audio device is connected and set the A2DP profile. –  cuichi Jun 5 at 23:27

4 Answers 4

I made it work the following way :

Before going further :

  • Update your system (I'm running 13.10)
  • Remove blueman
  • Install pulseaudio-module-bluetooth, pavucontrol (Utility to set up pulseaudio) and make sure bluez is installed
  • Remove any "Disable=Socket" or "Enable=Socket" entry in file /etc/bluetooth/audio.conf (edit with sudo)

Steps :

  1. Put device in pairing mode (even if already paired)
  2. Pair the device with your system using default bluetooth manager (blueman should have been removed) or if already paired go to step 3
  3. Select A2DP or Audio Sink connection for the paired device. If it fails try "sudo hciconfig hci0 reset" (where hci0 is your bluetooth device) check scan is ok with hcitool scan then retry this step (do hciconfig -piscan to identify your bluetooth device)
  4. With pavutools, select a2dp in "configuration" tab and your device in "Playback" tab / If a2dp is not selected, try pactl list cards short" to get your device id (1,2,3..) then do pactl set-card-profile X a2dp where X is your device id
  5. If it fails, restart avahi-daemon / bluetooth service and reset device through hciconfig hci0 reset. Check if scan is ok with hcitool scan. Then do steps 3 and 4
share|improve this answer
1  
Welcome to Ask Ubuntu! Very well done post. Just a minor thing to help improve your posts readability. If you have commands or file-names place tick-marks (`) around it to set it apart from the normal text. –  RPi_Awesomeness Dec 16 '13 at 19:48
    
Thanks for the detailed info. Quick questions: #3: "select A2DP or Audio Sink connection"... where from? #4 pavutools is apparently depreciated in jaunty & googling find nothing for installing it. I assume you don't mean Pulse Audio Volume Controls themselves? Thanks! –  dez93_2000 Aug 16 at 8:00
    
I've tried a number of different workarounds for this issue and so far this is the only one that has worked reliably. Thank you. –  mason81 Aug 29 at 16:54

You can try blueman application. This app can help you to play audio through A2DP streaming. You just have to mark your device profile as "Audio destination".

To install, use this command:

sudo apt-get install blueman

Open it by typing "blueman" in the dash.

I'll try to update the answer with necessary screenshot later

share|improve this answer

see if you have this package installed: pulseaudio-module-bluetooth although the fact that your other BT headset works would suggest so. It is a Mono device though, so it might be subject to different requirements. Also try referring to my question here, I just posted a solution that works for me. @Anwar Shah: Removing Blueman was also a part of that solution, just mentioning it.

share|improve this answer

Use Blueman with Alsa (packages are much leaner than pulse audio).

Pair and connect as "Audio sink", you'll hear a 'pop-b-b-b' on the headphones.

find /etc/alsa.conf or /usr/share/alsa/alsa.conf and append this to it;

pcm.btheadset {
   type plug
   slave {
       pcm {
           type bluetooth
           device XX:XX:XX:XX:XX:XX
           profile "auto"
       }
   }
   hint {
       show on
       description "BT Headset"
   }
}
ctl.btheadset {
  type bluetooth
}

The device ID you get from blueman once connected.

e.g mplayer -ao alsa:device=btheadset mysong.mp3

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.