Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new (from scratch, not update) installation of Ubuntu 12.10 on my notebook, Asus A3Ac (It is based on Intel Centrino - Pentium M with full duplex Intel HDA codec).

In older versions of Debian-based systems Intel HDA audio didn't work correctly. Alsamixer display wrong outputs and inputs (more than notebook really have). In clean installations internal speakers were playing, but they didn't mute when headphones was plugged in. There was a solution (propably not the best but working) - edit as root /etc/modprobe.d/alsa-base.conf and add a line "options snd-hda-intel model=z71v position_fix=1". After restart it worked correctly (alsamixer displayed correct devices and internal speakers were muted after I plugged in headphones). It was also working in Ubuntu 12.04.

In Ubuntu 12.10 I have another problem. The alsamixer in default (don't have to edit alsa-base.conf) display correct outputs and inputs but internal speakers don't working if the headphones isn't plugged in. I have to manually disable "Auto-Mut" option in alsamixer, then the internal spakers works (but of course they don't mute when the headphones are pluged in).

Thanks for any idea how to fix it. I'm not sure if it is a bug or it's caused by a "specific hardware".

Tomas

share|improve this question

1 Answer 1

had the same issue,

type alsamixer in terminal, navigate left to Auto-Mut and set it disable

@edit: sorry, just saw that you mentioned this already :D

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.