Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 12.10 quantal, the packaged version of fglrx no longer works. I discovered that this is because there is a separate 'legacy' fglrx driver for the HD 2k-4k series cards, but it is incompatible with the xorg server on 12.10.

This is the most current version of the driver for HD 2000 through HD 4000 series cards. You can't use the non-legacy fglrx driver, but you can use the open-source radeon driver if you prefer your WM compositing to be laggy and your YouTube videos to play like they would on a Pentium MMX series:

http://support.amd.com/us/kbarticles/Pages/catalyst126legacyproducts.aspx

Usually this driver can be installed in the following way, necessary because apt-get install fglrx would pull in the non-legacy driver:

wget http://www2.ati.com/drivers/legacy/amd-driver-installer-12.6-legacy-x86.x86_64.zip
unzip amd-driver-installer-*
sudo sh ./amd-driver-installer-*.run --buildpkg Ubuntu/quantal
sudo dpkg -i fglrx*.deb
sudo aticonfig --initial -f

If you use a different version of fglrx (for example, a newer 12.9 that doesn't support those cards) then the final command will give you an error no supported hardware detected or something similar. However, everything works at this point and you will get a reasonable xorg.conf:

... other stuff

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:5:0"
EndSection

... other stuff

At this point you're supposed to reboot and everything will be working with the fglrx driver. However, upon rebooting, you'll be treated to the following errors in Xorg.0.log when fglrx attempts to load:

(EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

Some searching around will show that this is a problem with the legacy ATI drivers not supporting xserver 1.13 or newer. (Arch Linux thread) ATI has released a fixed driver for its most recent (HD 5000 series or later) cards, but not for the 'legacy' cards yet. The non-legacy ATI drivers can't be used with the old cards.

What should an Ubuntu user, using one of these HD 2000-4000 series cards, do?

  1. Wait for an updated 'legacy' ATI driver that properly works with xserver 1.13?
  2. Downgrade back to 12.04 Precise, which uses xserver 1.11?
  3. Try to downgrade xserver on 12.10 Quantal to 1.12, which could possibly break Unity and GNOME?
  4. Forced upgrade to HD 5000 series or later card? (Not possible with integrated graphics...)
  5. Some other 1337 action that fixes this problem painlessly?
share|improve this question
    
My answer in a related thread. Might help you. –  Glutanimate Oct 26 '12 at 17:25
    

10 Answers 10

I have a Compaq Presario CQ56, with ATI Mobility Radeon HD 4250. Tried to use the ppa repository (as mentioned by lienmeat) and breaks my system with the legacy driver.

Actually, downgrading Xserver works well, but the fglrx not :S. In fact, ubuntu doesn't detect my card, son I can't even download the "privative driver" that the OS always suggested me.

In other words, I don't recommend install legacy with the method menciones above, the best desition us to wait for a fix

(Sorry for my bad english, i'm from Costa Rica, my english is not that good as my spanish xD)

share|improve this answer
    
Don't download the driver that the OS suggests. Install the catalyst 12.6 legacy driver that I linked to in my original question, then use the commands to install it. –  Andrew Mao Oct 23 '12 at 14:43
    
@egamboau If using 12.10, just don't install ATI drivers. They've failed on all the systems with 12.10 I've tried. Works like a charm in 12.04, though. The new xserver & Unity are not supported by fglrx, and Unity-2D has been discontinued. –  TomKat Oct 24 '12 at 12:35

If using AMD/ATI GPU drivers: Run the following command to remove them, and reboot:

$sudo apt-get purge fglrx

Don't reinstall them as ATI cards (rather AMD Catalyst) currently don't support Unity-3D.

As to the optionsyou have, I'd suggest #1: Wait for AMD/ATI to catch up.

share|improve this answer
1  
I have 12.04, and since this summer I am using RADEON drivers which for normal desktop use, in gnome-shell, works quite well. My card is: (--) RADEON(0): Chipset: "ATI Radeon HD 2400 Pro" (ChipID = 0x94c3) –  Rmano Oct 24 '12 at 9:49
    
@Rmano I've used ATI Radeon drivers on 12.04 myself without qualms. But the same drivers fail MISERABLY on 12.10. The reason behinds this are: a. New variant of Unity in 12.10. b. Unity-2D has been discontinued with 12.10. –  TomKat Oct 24 '12 at 12:29
    
this is dire news. Do you know if Radeon drivers works with gnome shell? I had my hand on the "update" button seconds before reading this. –  Rmano Oct 24 '12 at 13:47
1  
@Rmano The Radeon drivers (called fglrx) work well with gnome-shell, but not the new xserver. However, I believe that using open-source drivers for the time being should not be an issue. You can do pretty much decent gaming with them as well. Just wait for AMD to release something like an update or patch or for Canonical or other FOSS communities/developers to release something. I too let got fglrx for open drivers to upgrade to 12.10 and have no regrets whatsoever. –  TomKat Oct 24 '12 at 17:07
1  
Yes, open-source drivers work fine with xserver, Unity (3D) and gnome-shell. –  TomKat Oct 25 '12 at 14:09

Open source driver would work for me even considering less perfomance than fglrx, if it had a proper power consuption management.

I have Dell Inspiron 1545 with ATi Radeon 4350, and unfortunately open source driver seems not to manage GPU cooler state. The cooler was always on and running loud, nevertheless the system/graphics load. Once I downgraded the X server to 1.12.3 and installed legacy driver, as suggested by Fglrx on Launchpad (the same as lienmeat suggested us to do), GPU cooler started to work only if needed. Bless you silence of the coolers.

However, it would be great if AMD released legacy drivers supporting newer X server(s), though now I'm not sure they really care.

share|improve this answer
    
Eh, my laptop is this one: forum.notebookreview.com/acer/… Terrible design. Right now i have temp1: +57.0°C (crit = +90.0°C) on the gpu idling with nothing but firefox, about 10+ degrees than the closed drivers, and that's on always 'min' power setting, on 'medium' it crashes sometimes during the first minutes (a process that is doing a mimetype file database). –  i30817 Mar 23 '13 at 9:05

Repo for putting last good proprietary driver : http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Nov 4 '12 at 22:59

I have ATI Mobility 4650 HD and installing this broke my unity and opengl. I got things working with this (found here):

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

sudo rm /etc/X11/xorg.conf

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg

sudo reboot

I hope this helps until there is an official driver release by ATI.

share|improve this answer

A workaround for this problem is posted at http://ubuntuforums.org/showthread.php?t=2073279

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Nov 4 '12 at 22:58
    
This thread helped me fix fglrx-legacy install after using the recommended approach above. By doing these: sudo apt-get purge fglrx-amdcccle-legacy fglrx-legacy-dev fglrx-legacy sudo rm -R /usr/lib/fglrx sudo rm -R /usr/share/ati –  gare Feb 15 '13 at 14:28

I have an ATI Radeon HD 4770 and the open source drivers are working quite nicely. I don't know which card you have, but you may end up having better luck than with fglrx and downgrading your xorg. I used fglrx for years and this summer switched over to the open source drivers and haven't looked back.

Granted, some effects in Compiz are slower using the open source drivers. Also, 3D gaming is noticeably slower without fglrx. However, for most of your desktop use, the open source drivers are much easier to use than fglrx, with the added bonus of being actually supported.

(Incidentally, the Gnome Shell packaged in 12.10 works very nicely with the open source drivers, and is much faster than Compiz/Unity!)

share|improve this answer
    
I have a chipset integrated Radeon HD 4290 which is in dire need of fglrx. I think with more powerful cards like your 4770, there is some breathing room for the open source drivers to be somewhat blah and the compositing to still work well...but not the case for my low end integrated card. –  Andrew Mao Oct 23 '12 at 18:48

There's the ppa:makson96/fglrx PPA that has the legacy driver. It will also downgrade your Kernel and X server to older versions, as the legacy driver is not compatible with newer Kernels nor X servers. However, please read the release notes from the link as the driver isn't fully compatible with the Unity used in Ubuntu 13.04.

If you want to use the PPA, run these commands from the terminal to downgrade the Kernel and X server and to install the legacy driver:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy
share|improve this answer

I have an old Radeon Mobility HD 2600 on 13.04. It did not suffice for me to install the above repository (makson), because when checking Xorg -version it had not downgraded Xorg.

What I finally ended up doing was rebooting into recovery, removing all xorg packages (which triggered removal of the package ubuntu-desktop (gulp)) and then reinstalling the packages again. This triggering the retrieving of the packages from the repository.

Something like:

sudo apt-get remove xserver-*
sudo apt-get autoremove
sudo apt-get install ubuntu-desktop

Have to play around with it! After that I got into a high-resolution desktop. Just reset Unity, enable the OpenGL plugin in ccsm and we're good to go!

share|improve this answer

Guys If You Have any Graphics Resolution problem.

Just go to update manager-->Additional drivers-->select the default driver and reboot.

share|improve this answer
    
You might want to tell folks how to do this without a GUI since having no GUI is what got them here in the first place. –  Dale E. Moore Dec 25 '13 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.