Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using the Vi editor on my desktop Ubuntu 12.04, and do no have any problems. But a few days ago, I installed the Vi editor to my beagleboard-xm which has both Angstrom and Ubuntu 12.04 available but noticed that I cannot activate the insert mode at both of the Op. Systems. How I understood that:

When I press i or I, I do not get a warning on the bottom, just -- INSERT --. But if I continue and if I press k, the cursor moves to the line above, and if I press j, the cursor moves to the line below. If I try to put a # to comment out something, the cursor moves randomly and according to warning written at the bottom: "search hit TOP, continuing at BOTTOM", etc. etc.

How can I get into insert mode? Any suggestions?

share|improve this question
    
open vi and try to set :set showmode. Then try "Esc - i(insert mode)" –  devav2 Oct 19 '12 at 21:26
    
@devav2 I tried what you suggested, first at the bottom -- INSERT -- warning has written but when I pressed the arrow keys that warning disappeared and same behavior continues. –  Xentius Oct 19 '12 at 21:39
add comment

3 Answers 3

Try the a key for the same -- INSERT -- operation. It should work just like i. AFAIK, it works on Ubuntu 12.04 and Raspbian.

share|improve this answer
add comment

Install Vim as it is an improved version of vi.

sudo apt-get install vim

To open a file with vim, you have to use vim command insteat of vi

vim abc.txt
share|improve this answer
1  
Even though your answer will work, it would be nice to know, why you suggest to install it. –  MadMike Oct 15 '13 at 6:58
    
Just because, vim is an improved version, Simple. –  bioinformatician Oct 15 '13 at 8:50
1  
I know. I meant it as a suggestion on how to improve your answer. Please, hit the edit link on your answer and add the information there. –  MadMike Oct 15 '13 at 8:53
add comment

I had same problems, but they successfully resolved when I noticed default keymap not EN. Since that I use INSERT key and have no problems )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.