Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

During the upgrade from 12.04 to 12.10, grub-pc failed to update.

dpkg: error processing grub-pc (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 grub-pc

I have already tried apt-get purge grub-pc and reinstalling it, but the same error keeps coming up.

During the upgrade a few windows from Grub popped up asking me if I wanted to keep or replace the configuration files for Grub. I clicked the "keep" button on all of them. I suspect that might be the problem

share|improve this question
    
Related: Can't load GRUB all of a sudden (UEFI problem). I've experienced the "failure" of grub-pc to update, but it may be a blessing on a UEFI-enabled system, in that grub might stop working if updated. –  hardmath Feb 8 at 0:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.