Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Quantal Quetzal and when I type sudo in the terminal it asks for the password. Before upgrading, I changed something in the file, and it wouldn’t ask for passwords. I have already tried advice from many websites, but none of them worked. Does 12.10 differ with sudo in any way? If anyone can tell me which file to change to fix this, that will be great.

share|improve this question

1 Answer 1

up vote 6 down vote accepted

Your main user is member of group 'sudo'. Default settings is to ask your password in order to perform any activity which requires some privilegies.

in order to change it, you need to run in a terminal:

sudo visudo

and change this line:

%sudo   ALL=(ALL:ALL) ALL

for this line:

%sudo ALL=(ALL:ALL) NOPASSWD: ALL

save the changes and close your session to have your system taking the changes.

share|improve this answer
    
thanks, it worked –  Nick Bailuc Oct 19 '12 at 21:02
    
Do you know how to remove the attempt in the Software Centre? –  Nick Bailuc Oct 19 '12 at 21:07
1  
@NickyBailuc That's PolicyKit; that's different. –  hexafraction Oct 29 '12 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.