Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I started the video and it says it has no codex and it can search for it(it looked cool) and it has downloaded them and video works great, but for some reason all the faces on videos I'm watching are blue, how to make them not blue?(I bet its a common problem).

P.S. I'm not prejudiced against aliens, I just don't like them.

share|improve this question
    
wich media player are you using ? DId you try for example play the video in VLC ? ( sudo apt-get install vlc ) or mplayer ? –  Luciano Facchinelli Jan 17 '11 at 12:27
1  
@Luciano Facchinelli mplayer, but i also tried some other player at i has the same problem. I think its because of installed codecs :( –  UAdapter Jan 17 '11 at 19:02
1  
Are you watching Blue Man Group? ;) –  OrangeTux Aug 16 '12 at 8:47
add comment

9 Answers 9

up vote 3 down vote accepted

I'm running 12.04 LTS with a Nvidea GeForce 8400M GS (512 MB). SMPlayer (vers. 0.81) is my default playback app. & Totem Movie Player 3.0.1 (Movie Player using GStreamer 0.10.36)

All movies opened from hdd show "blue faces". Yet sometimes when opening "Nvidea XServer Settings", the next video I play is in normal colors. (only once...opening the same movie again will show blue faces again)

FIX :

Download and install "Sysinfo" app. and open it. Select "Nvidea" - "Nvidea Display Settings". Under "X Screen 0" select "X Server Xvideo Settings". Slide the "Hue" controller all the way down to zero.

If this didn't help (in my case no option to save this setting, but only the option to "quit" Nvidea XServer Settings"), open Totem Movie Player ;

Open the video and check for "blue faces". Let the video continue playing. Go to "edit", "Preferences", "Display" : Slide the "Hue" controller to zero. While you're sliding the Hue down, you will see the colors change to normal.

In my case the changes made in Totem Movie Player where also adapted in the SMPlayer and all videos are playing in normal colors now.

share|improve this answer
    
Thank you so much for this. I did the nvidea hue setting and it fixed it for me! –  Vicer Nov 23 '12 at 9:41
add comment

In the bug report that Clausi links there are quite a lot of workarounds.

This tip from Le Glun de net looks like the best aproach to me.

If you have this bug (blue and red color in video are invert) and you have a nvidia, you don't have to install or uninstall any software. Just launch the "nvidia X server settings", choose your screen (X screen 0), "Xserver video settings", "Reset hardware defaults".

Note that it seems to correct itself as soon as you open the Nvidia setting for some people.

share|improve this answer
    
i do have Nvidia, I will try this later at home, thx. –  UAdapter Jan 18 '11 at 8:24
1  
it did not help, but thx. –  UAdapter Jan 23 '11 at 6:54
add comment

" 1. Open gstreamer-properties (alt+f2, enter gstreamer-properties)

  1. Change to the video tab

  2. Change the default output plugin to "custom"

  3. Place the following command in the bottom box: videobalance hue=-1 ! autovideosink

  4. Close the box and enjoy your now correct colour "

share|improve this answer
add comment

From https://bugs.launchpad.net/ubuntu/+source/nvidia-settings/+bug/395476:

  1. open totem via Applications > Sound & Video > Movie Player
  2. open the preferences window via Edit > Preferences
  3. select the Display tab
  4. click the Reset to Defaults button
share|improve this answer
1  
thx for cool idea, but it did not work for me. –  UAdapter Jan 7 '11 at 17:35
add comment

this seems to have a couple of different possible causes.

Most likely you can fix this by just using a different output method in mplayer. try:

mplayer -vo xv movie.avi

or

mplayer -vo gl movie.avi

There are similar flags for other players like vlc, and I'm sure it's in the settings page of your favourite GUI also. (I know it's in vlc and smplayer at least)

share|improve this answer
1  
"mplayer -vo gl movie.avi" has worked, thx a lot :D –  UAdapter Jan 23 '11 at 6:53
add comment

Create a file /etc/adobe/mms.cfg if it doesn't exist

Add the lines or change values to:

EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

Solution from: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/974620

share|improve this answer
add comment

For me it whas The video output i had set to Directx (direct draw). I changed it to Open GL and it whas gone. Seems Direct Draw actualy draw the skins blue. Kinda funny real life smurf people. Im using Vlc player and had lots of trouble Turned on Gpu for lagging and Hardware acceleration. Video codec to Open Gl. Still not working good but faces are not blue anymore and is best i can get right know.

share|improve this answer
    
Ok so now i chainged the buffer to 3500ms. And now it actually works how it should. No blue faces and no lag. Hope it will be like this also tomorow when i try again –  Siggie Aug 19 '13 at 23:19
add comment

Apart from the rest of suggestions, which I'd follow, if everything fails try installing latest nvidia drivers (if you're using them)

share|improve this answer
add comment

Have you tried another media player? which one are your using?

I would try to play the video in VLC ?

 sudo apt-get install vlc

or mplayer

share|improve this answer
    
mplayer, but i also tried some other player at i has the same problem. I think its because of installed codecs :( –  UAdapter Jan 18 '11 at 8:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.