Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to setup my printer under Ubuntu. So far it worked that i succeed to install the drivers. But Ubuntu says: No driver available for this model. This is the problem that Ubuntu doesn't recognize the right model, so i have to add and the choose the right driver manually. No problem i thought. But when i try to add a printer, i'm prompted to provide a root password althought i didn't setup one? So i'mnot able to confirm the dialog and add my printer, what's the reason?

alt text

alt text

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Try to set a root password, if you realy want to log as root. In terminal type: "sudo passwd root" (without quotes).

share|improve this answer
    
Thanks, this worked so far as a workaround. It was also mentioned here.bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/… –  NES Jan 6 '11 at 19:10
    
Setting a root password is considered a bad idea, also mentioned in the bug report. The gksudo solution mentioned is better. –  MichielB Oct 29 '12 at 11:12

If you don't want to hassle with the root passwords you can just do: gksudo system-config-printer

share|improve this answer
1  
This is the best workaround. I found it was because I messed with users and groups on my system and I was not a member of the lpadmin group. To add yourself to this group you can run 'sudo usermod -aG lpadmin yourusername'. –  MichielB Oct 29 '12 at 11:11

Use your normal password - the root password is disabled in ubuntu.

Normally when su is required use sudo.

You can if needed get a root shell with sudo -i

https://wiki.ubuntu.com/RootSudo

share|improve this answer
    
the normal password doesn't work. –  NES Jan 6 '11 at 17:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.