Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How can I fix a 404 Error using a PPA?

When I run "software updater" I get the following message: Don't know what this could be, as my internet connection is perfectly fine. Any suggestions?

  W:Failed to fetch http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/dists/quantal/main/source/Sources  404  Not Found,
  W:Failed to fetch http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found,
  E:Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question

marked as duplicate by devav2, belacq, Uri Herrera, Ringtail, Mitch Oct 20 '12 at 5:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

It looks like you added the Ubuntu-X-Swat PPA, which is for the latest updates to video drivers and display-related stuff for Ubuntu, and the PPA itself appears to be unavailable for Ubuntu 12.10.

Basically what it means is that your update manager tried to see if there were updates for certain stuff, but it couldn't find out if there were updates available because the source of the updates itself isn't available.

It's not usually a big deal, but I'd go into Software Sources and remove the Ubuntu-X-Swat PPA, since the PPA is not doing anything right now other than giving you grief when it's time to install updates.

share|improve this answer
    
Thanks guys, the guy that revised my question posted a link for the problem and I solved it through here askubuntu.com/questions/65911/… I was initially trying to repair my graphics card Nvidia 6150SE because after resuming suspend I would always get scratchy desktop, not sure if its okay now need to check. Nonetheless thank you for the answers! –  ed-2012 Oct 19 '12 at 20:00

I think you have to remove following PPAs.

Open "Update Manager" > then click on "Settings" > in "Other Software" tab > remove these links:

http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/dists/quantal/main/source/Sources
http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/dists/quantal/main/binary-i386/Packages

PPAs are additional software sources which are not in default Ubuntu Software Source, so by adding these APPs you can connect you apt-get (software center) to other sources, when these software sources stop their support, this problem happened. so simple just check links if they are correct (have content) you have to find why apt-get update can not detect packages, but when the link is not working (like this case) it means no more support by software makers, in similar cases, simply remove APP link from apt-get as i told you.

here is my source list (as you see, i just have Google as a non-official Ubuntu package source): enter image description here

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.