Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Lenovo ThinkPad Edge E420s. I have changed Fn key behaviors from bios so that F1,etc are defaults and media keys are only accessible with Fn key. I also made Fn key to work as toggle key and swapped Fn key with Ctrl key.

After every reboot F-keys work just like I expect, but after some time they revert to the factory default settings (media keys are defaults and F-keys are accessed with Fn key). Fn key toggle behavior also stops working, but Ctrl and Fn key positions stay as they were set in bios. After rebooting everything works fine for some time.

I had similar problem with Ubuntu 12.04, but somehow I figured that this happened only after the display turned off, so the fix was to keep display always turned on. I tried same thing with Ubuntu 12.10, but that doesn't work anymore.

I tried to look some hints from log files but I found nothing relevant that might explain this behavior.

I also tried rebinding media keys to F keys, but F1-3 keys all send Volume Mute key events, so that won't work.

Rebooting every few minutes just to keep F keys working is starting to get very old after a while.

I have never had same problem in Windows 7, so it must have something to do with Ubuntu. It just sounds strange that os could change bios settings.

UPDATE:

Just noticed that after a while when F-keys stop working they start working again, without any obvious reason or indication.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.