Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I upgraded from Ubuntu 11.10 to 12.04 (and also 12.10 problem still occurs), my notebook does not lock the screen automatically.

I wen into "Brightness and Lock" settings, Set "Turn Screen of when inactive for 1 minute" and also the "Lock screen after 1 minute". But the screen never locks.

The screen goes off, and after certain Random Time it goes back on, and NOT locked. So, if i leave my office, the screen turns off, but suddenly after a while it turns back on, and anyone can access my computer.

Obs.: Ubuntu 12.10 x64, Gnome-shell 3.6.1, Dell Integrated Graphics.

share|improve this question
1  
Have you added or removed xscreensavers or gnome-screensavers? –  belacqua Oct 26 '12 at 15:48
2  
I'm having the same problem. Won't lock unless I try it once with ctrl-shift-l –  joeradtke Oct 28 '12 at 19:20

2 Answers 2

I was having the same issue on 12.10. Everything worked fine in 12.04, but the problem started when I upgraded to 12.10 yesterday.

I figured out that I was just misunderstanding the wording of the 12.10 Brightness and Lock settings. There are two parts. "Turn screen off when inactive for:" x minutes, which determines when the screen turns off. Then "Lock screen after:" x minutes determines how long after the screen goes off to activate the screen lock. So you have to add the two times to get the total time after which the screen will lock. Hope this helps.

I found the solution here: https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/1063682

share|improve this answer
    
Seems that this problem is back now after an upgrade on November 1st to gnome-screensaver. Screen doesn't lock automatically, but does work with ctrl+alt+l. –  wchest Nov 1 '12 at 16:38

in my upgrade to 12.10 (using the USB stick method) I found the screen never locks regardless of the settings in the system B&L setup HOWEVER if I use Ctrl-Shift-L it will lock and then will lock on subsequent screen blanks.

so there must be some legacy config option that is not affected by the Brightness and Lock utility that neglects to install the screen-saver to automatically start the daemon upon session login. Does anyone know where this might be set or if there is some other programmatic way to initiate the daemon other than having to remember to do at least one ctrl-alt-L on each new session?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.