Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today, I updated to Ubuntu 12.10. After re-starting, like the updater suggested, the toolbar on the top of the screen, and the dash won't load. I seem to be missing other features, as well, like alt>tab to switch windows, etc.

I am able to access the Terminal, by typing Ctrl>Alt>T, which is how I was bale to access Firefox.

How do I fix this problem?

Edit: 10/20/12

I resorted to completely re-installing Ubuntu. If someone finds a way to fix this problem without completely re-installing, please feel free to post it below.

Edit: 5:18 PM on 10/19/12

I am probably not the only one who has noticed this, but I just found out that Ubuntu works fine if booted into Gnome. The probalem seems to be with Unity, and people have been saying it's also a problem with ATI graphics cards.

I have tried many of the suggestions in the other threads that have been suggested, and nothing seems to work. Other idea's would be appreciated!

Edit: 2:10 PM on 10/19/12

As Chris Carter suggested, I'm including the results of the teminal command lspci here is my graphics card info:

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780M/RS780MN [Mobility Radeon HD 3200 Graphics]

share|improve this question
Do you have an ATI/AMD graphic card? – Chris Carter Oct 19 '12 at 19:36
Yes. The sticker says "AMD Athlon X2 64" – pgrytdal Oct 19 '12 at 20:12
That is your processor, open a terminal and include the results of lspci in your question. – Chris Carter Oct 19 '12 at 20:28
up vote 0 down vote accepted

To be honest I am still trying to get my head around this myself.

I had the same problem after doing an upgrade myself and it appears that Ati have yet to add support for the latest x-server.

I myself ended up doing a clean install and although I now have a usable desktop it is not taking full advantage of the capabilities of my card. I have not attempted to install fglrx as I am sure it will break my system.

There are others asking questions like this e:g Radeon HD 2000, 3000, 4000 on 12.10 Quantal: fglrx 12.6 unsupported, what to do?

There is probably a way to uninstall fglrx properly to get to a usable system that someone more learned than I can explain.

share|improve this answer

12.10 Unity GUI Not Displaying

the above url provide fixes for this depending the kind of cpu & gpu you are using for removing fglrx worked and restored the unity gui back !

share|improve this answer
Please refrain from posting two similar answers. Edit your original post to add details to it and remove the latter one. Thank you. – Peachy Oct 28 '12 at 6:39

The exact same thing happened in my laptop, I have a discreet card, the Intel one that comes integrated with the processor and an nvidia card: GeForce GT520M Cuda 1GB. I too noticed that I could log into gnome just fine. I'll try removing any graphic card drivers (flgrx if it is there and the nvidia ones) and see if it takes off.

share|improve this answer
Well, @MAnju 's answer did the trick, I installed bumblebee and it solved the problem! – Flatline Nov 9 '12 at 13:49

I had to remove the flgrx and any nvidia in mine before it fixed the problem. Removing just the flgrx didn't work for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.