Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Has anyone tryed CUDA on Ubuntu 12.10 with Blender or another programm? In the last beta of Quantal CUDA wasn't working. I would like to update from 12.04 to 12.10 final but only if CUDA still works. Is there someone who already has experience with this? Thanks

share|improve this question

3 Answers 3

The installation of CUDA 5.0 fails on ubuntu 12.10 :

$ uname -a
Linux yoyo-laptop 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:        12.10
Codename:       quantal

$ cd /opt

$ sudo wget -c http://developer.download.nvidia.com/compute/cuda/5_0/rel/installers/cuda_5.0.35_linux_64_ubuntu11.10.run

$ md5sum cuda_5.0.35_linux_64_ubuntu11.10.run
dd82e9d1c5739806690c311e2f56c928  cuda_5.0.35_linux_64_ubuntu11.10.run

$ sha1sum cuda_5.0.35_linux_64_ubuntu11.10.run
bae5870868217bb0bc07d53a7e824301f9752e6a  cuda_5.0.35_linux_64_ubuntu11.10.run

$ sudo chmod +x cuda_5.0.35_linux_64_ubuntu11.10.run

$ sudo update-alternatives --install /usr/bin/gcc cc /usr/bin/gcc-4.5 50

$ gcc --version
gcc (Ubuntu/Linaro 4.5.4-1ubuntu2) 4.5.4

$ sudo ln -s /usr/lib/x86_64-linux-gnu/libglut.so /usr/lib/libglut.so

$ sudo ./cuda_5.0.35_linux_64_ubuntu11.10.run -verbose -optimus

Do you accept the previously read EULA? (accept/decline/quit): accept

Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 304.54? ((y)es/(n)o/(q)uit): y

Install the CUDA 5.0 Toolkit? ((y)es/(n)o/(q)uit): y

Enter Toolkit Location [ default is /usr/local/cuda-5.0 ]:

Install the CUDA 5.0 Samples? ((y)es/(n)o/(q)uit): y

Enter CUDA Samples Location [ default is /usr/local/cuda-5.0/samples ]:

Installing the NVIDIA display driver...

Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 304.54...............................................................................................................................................................
Installing the CUDA Toolkit in /usr/local/cuda-5.0.
Verifying archive integrity... All good.
Uncompressing NVIDIA CUDA..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
===========
= Summary =
===========

Driver:   Installation Failed
Toolkit:  Installation Failed
Samples:  Cannot find Toolkit in /usr/local/cuda-5.0

Logfile is /tmp/cuda_install_30203.log
share|improve this answer
    
For Reference, it works following those instructions: devtalk.nvidia.com/default/topic/522699/… (including changing gcc/g++ to use 4.6 [or older] and the soft link for the glut library otherwise you cannot install the samples; it's all documented on that page.) –  Alexis Wilke Dec 27 '12 at 6:54

First install gcc-4.4 and g++-4.4 then make a symlink of sudo ln -s /usr/bin/gcc /usr/bin/gcc-4.4, it is not too clean but probably you should delete first the symbolic link of /usr/bin/gcc.

share|improve this answer
    
It worked for me with gcc-4.6. Any reason why you would choose 4.4? –  Alexis Wilke Dec 27 '12 at 6:59

Simplest solution is:

It detects then cuda gpu without any problems. (Of course assuming that you have propersly installed latest propietrary nvidia drivers)

Yep, i know that is not that elegant as making it work when installed from repo or ppa, but for me most important is that works, so i can use blender and cycles.

If you dont need the cuda toolkit (for develping etc) i think it is acceptable workaround for you too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.